ofxPoco with Android (ofxHTTP)

I am trying to use ofxHTTP with android. When I try to compile it I get a lot of errors. At first these were related to Poco headers not being found. Here is a forum post and an issue son Github that relates to this:

The solution was not so elegant, but I managed to use a solution from this post:

However the post suggests adding:

android/arm64-v8a:
	ADDON_INCLUDES = libs/poco/include/%
	ADDON_INCLUDES += src
	ADDON_LIBS = libs/poco/lib/android/arm64-v8a/libPocoNetSSL.a
	ADDON_LIBS += libs/poco/lib/android/arm64-v8a/libPocoNet.a
	ADDON_LIBS += libs/poco/lib/android/arm64-v8a/libPocoCrypto.a
	ADDON_LIBS += libs/poco/lib/android/arm64-v8a/libPocoUtil.a
	ADDON_LIBS += libs/poco/lib/android/arm64-v8a/libPocoJSON.a
	ADDON_LIBS += libs/poco/lib/android/arm64-v8a/libPocoXML.a
	ADDON_LIBS += libs/poco/lib/android/arm64-v8a/libPocoFoundation.a

To the ofxPoco addon_config.mk, however to make it actually find the files I needed to remove these lins from the android sepcific configs:

ADDON_INCLUDES = libs/poco/include/%
ADDON_INCLUDES += src

As well as removing all ADDON_INCLUDES and ADDON_EXCLUDES from the common part of the addon_config.mk.

This led to Android Studio finding all the required header files.

However I still get many issues, described in this github issue:

Namely this is many errors that look like:

error: no type named 'string' in namespace 'std'
        Exception(const std::string& msg, int code = 0);

I can compile all of the Android examples, but nothing that uses ofxPoco.

I have tried this on multiple versions of Android Studio on OSX and Windows 10, Android Studio 2.3.3 seems to work well (other versions do as well, I can compile the examples with 3.1.4), but this 2.3.3 seems to be from around the time that the toolchain was last updated and contains the correct JDK and Gradle versions. I am using the required NDK (obviously as it compiles). I have also tried with the nightly builds and also 0.11.2, but cannot find a solution.

Does anyone have a fix for this that works?