ofxPd with 0073, linux, problems

Hey Guys,

im having some problems compiling the ofxPd addon. i tried to checkout from git especially for 0073 but only got 007. i added all flags into config.make. i finaly get the following error which i dont know how to solve. any ideas?

  
g++: error: unrecognized command line option ‘--export-dynamic’  
make: *** [bin/example] Error 1  
  

i am using ubuntu 12.10. and of 0073. building with make.

Hi Rak, did you find a solution to this??

hallo defchild,

unfortunately not. did you?

i got the same error in Ubuntu64 bit 12.04 and OF 0074 but if i comment out the --export-dynamic line the example compile and works fine.

i did a short trial. it worked but brought me to the next error.

  
/usr/bin/ld: cannot find -llibopencv_legacy.a  
/usr/bin/ld: cannot find -llibopencv_haartraining_engine.a  
/usr/bin/ld: cannot find -llibopencv_calib3d.a  
/usr/bin/ld: cannot find -llibopencv_objdetect.a  
/usr/bin/ld: cannot find -llibopencv_features2d.a  
/usr/bin/ld: cannot find -llibopencv_imgproc.a  
/usr/bin/ld: cannot find -llibopencv_video.a  
/usr/bin/ld: cannot find -llibopencv_highgui.a  
/usr/bin/ld: cannot find -llibopencv_ml.a  
/usr/bin/ld: cannot find -llibopencv_legacy.a  
/usr/bin/ld: cannot find -llibopencv_core.a  
/usr/bin/ld: cannot find -llibopencv_flann.a  
/usr/bin/ld: cannot find -llibopencv_contrib.a  
/usr/bin/ld: cannot find -llibopencv_gpu.a  
  

i think those are path problems. will check it when i have more time… soon…

Are you using ofxOpenCv with ofxPd? or are you testing the ofxPd example addon?

trying to compile the ofxPd addon…

Hi Rak & Kalwalt,
I too am trying to add the ofxPd addon example w/ the latest android OF. It seems ofxPD, is maintained but a few revisions of the latest OF. I saw OF 062.

I can get Release to build, but no luck or time to deeply debug the Debug configuration. When I get it working, I’ll post my project and steps :slight_smile:

Okay, I got the ofxPd example finally working on my Galaxy Nexus with the latest ADT (SDK tools & Eclipse) from Google and of_v0.7.4_android_release and the recommended NDK of r8d. I’m running MacOS 10.7.5

Generally, what I’ve noticed is that once you’ve built a project in Eclipse, and then change a bunch of things (like add new files etc) many times those changes are not picked up (even after refreshing F5). Furthermore the Clean target doesn’t work like I expect and I often just delete the obj/src/*.o files to force them to be regenerated. I also deleted the project (not the libs, of ofx src) and readded it to my workspace, whenever I would not see “changes”. All this is a nuisance and definitely not ideal.

To get ofxPd example working, I did the following:

  • Build and run the androidAudioExample - It builds for me out of the box on of_v0.7.4_android_release

  • Close down Eclipse and replace the AppCore.* and TestApp.* from the ofxPd example src folder. Don’t replace the main.cpp (as it contains Android specific #defines) Also to be sure delete the object files in obj/src/*.o in your project.

  • Add “USER_CFLAGS = -DHAVE_UNISTD_H -DUSEAPI_DUMMY -DPD -shared”
    “USER_LIBS = -ldl -lm” to the config.make. DO NOT add “–export-dynamic” (as documented by danomatika)

  • Add ofxPd to addons.make (as documented by danomatika)

  • Add to the AndroidManifest.xml You need this to be able to put the resources onto the phone’s sdcard w/o errors.

  • Restart Eclipse and rebuild. You might need to delete the project from the workspace (keep files of course) and re-add it back to the workspace.

When the build finishes, you should be ready to go.
I just did this, so its fresh in my mind. Let me know if I’ve missed anything or if you have any troubles!

cheers,
d