ofxPd clashes with Music IO (iOS midi app)

I’m using ofxPd on the lastest OF 0.9.0 to create an iOS app. I also use ofxMidi all created by Dan Wilcox.

Music IO is an iOS app that allows one to transmit MIDI via USB cable.

If I run my app not using arm64, it worked fine with Music IO.

But if I use arm64 for 64bit support, as soon as I open Music IO app, sound of my app gets seriously distorted.

It still transmits MIDI data but the audio starts to get distorted as soon as I open Music IO app.

I really don’t know what is causing the problem.

Could it be because of ofSoundStreamSetup which is based on RtAudio library?(if Music IO is also using RtAudio as well)

I would really appreciate if someone can give me an advice regarding the possible solution for this.

Also, If I open Music IO first, and then open my app, it crashes caused by the following error.

It no longer crashes if I remove this from the code, but then I can’t use ofxpd.

if(!pd.init(2, 1, 44100, ticksPerBuffer, false)) {
    OF_EXIT_APP(1);
}