ofxOpenNI setup

Hi,

I am trying to setup this addon I got from git, I follow the instructions, but I get the following error:

dyld: Library not loaded: @executable_path/./…/…/…/data/openni/lib/libOpenNI.dylib
Referenced from: /Users/nardove/Programming/openFrameworks_master/my apps/Kinect/ofxOpenNIExample/bin/emptyExampleDebug.app/Contents/MacOS/emptyExampleDebug
Reason: image not found
sharedlibrary apply-load-rules all
Data Formatters temporarily unavailable, will re-try after a ‘continue’. (Cannot call into the loader at present, it is locked.)

Any help will be much appreciated.

Cheers

  • rS

Have you follow these step described on: github.com/roxlu/ofxOpenNI/tree/experimental ? Specially the last one

INSTALLATION

Go to your addons directory, and follow these commands

git clone https://github.com/roxlu/ofxOpenNI.git
cd ofxOpenNI
git checkout experimental

HOW TO SETUP YOUR APPLICATION

  • In XCode, create a new group “ofxOpenNI”
  • Draw these directories from ofxOpenNI into this new group: ofxOpenNI/src
  • Add a search path to: …/…/…/addons/ofxOpenNI/include/
  • Copy the “ofxOpenNI/mac/copy_to_data_path” to your bin/data directory of your application.
  • Drag and drop the file: bin/data/openni/lib/libOpenNI.dylib into your project

Hi,

I’ve changed
context.initFromXMLFile() to
context.setupUsingXMLFile();

this gets rid of that error. But I have one remaining error. Has anyone experienced this or knows what it means? Perhaps the "duplicate symbol CreateRainbowPallet() " part below??

thanks
Andrew

ld: warning: directory ‘/Users/robertson/Documents/work/programming/of_preRelease_v0062_osxSL_FAT/apps/my_SL_openFrameworks/openNiExample/…/mac/copy_to_data_path/openni/lib’ following -L not found

ld: warning: directory ‘/Users/robertson/Documents/work/programming/of_preRelease_v0062_osxSL_FAT/apps/my_SL_openFrameworks/openNiExample/…/mac/copy_to_data_path/openni/lib’ following -L not found

ld: duplicate symbol CreateRainbowPallet() in /Users/robertson/Documents/work/programming/of_preRelease_v0062_osxSL_FAT/apps/my_SL_openFrameworks/openNiExample/build/opennisample.build/Debug/emptyExample.build/Objects-normal/i386/ofxDepthGenerator-2904E4D848C0F730.o and /Users/robertson/Documents/work/programming/of_preRelease_v0062_osxSL_FAT/apps/my_SL_openFrameworks/openNiExample/build/opennisample.build/Debug/emptyExample.build/Objects-normal/i386/ofxDepthGenerator-2904E4D848C0F730.o
collect2: ld returned 1 exit status
Command /Developer/usr/bin/g+±4.2 failed with exit code 1

actually this looked like a duplicate library problem.

I now have it running - great - but all i see is a person in blue before a green yellow room etc - no skeletons etc. What should i be seeing?

Thanks
Andrew

I think all you need to to do the calibration pose, check out this video http://www.vimeo.com/17640133

Cheers

  • rS

you’re right! - thank you

for future users = the main points i came across:

  1. follow the instructions that patricio gives above. In particular, once you have bin>data>openni
    (containing libs), drag that particular libOpenNI.dylib to the project
    make sure you’ve added the appropriate addons

  2. when you errors on ofVec2d etc - change to ofxVec2d

  3. I think I needed ofx3dutils - got folder in my addons, then dragged this into the project so that it gets found. (this may not be necessary)

  4. change context.initFromXMLFile();
    to
    context.setupUsingXMLFile();

  5. uncomment the draw code:
    depth.draw(0,0,640,480);
    user.draw();

once it compiles

  1. strike the pose!

This was using openFrameworks 0062 Snow Leopard

Hi , I’m getting that error too , I don’t get this part of readme :
“Drag and drop the file: bin/data/openni/lib/libOpenNI.dylib into your project” it means just dropping it and it will be below the project name and above src folder? or it means something else?
thanks

thanks for tons of answers :slight_smile:

Thanks for so much support

I’m also running into the same error, even though I tried to follow the instructions to the letter. I’ve attached two screen shots showing my file/project setup, is it obvious where I went wrong?