ofxOMXPlayer latest version not looping?


#1

Hi
I’ve just been trying out the new ALSA support in ofxOMXPlayer (thanks @jvcleave!) which works really well but for some reason i’m having trouble looping videos, which has never been an issue before…

With looping enabled, the video holds on the final frame and reports ‘reached end of stream’ but doesn’t seek to the start as it used to. The frame counter keeps running…

I’ve tried the basic and direct mode examples, with and without alsa, on a Rpi b+ running stretch and OF0.10, with 128MB for the GPU.

Has anyone tried this? I’m wondering if it’s something about my set-up…

r


#2

if you want to open an issue on github and maybe post a link to the file that won’t loop I could take a look

the only looping issue I have run across has been with h264 stream files or network streams but omxplayer couldn’t loop those as well


#3

thanks for getting back to me — it’s odd - i’m just using the bunny1 file from the addon folder …

I’ll try another Pi when i can hold of one


#4

try bumping up the GPU memory to 256


#5

…it’s running very nicely on a Pi3 - same versions of everything…I’ll give it a go on a different PiB+ if i get chance at work next week to see what happens but it does look like there’s something not right with my B+…

Thanks for your time, much appreciated. it’s a great addon.

r


#6

…got to the bottom of it - Permissions were set to root:root on my openFrameworks/addons/obj folder for some reason…
Changed them to pi:pi, recompiled and everything’s fine
R