ofxNetwork connect bug

I have been trying to setup a server/client app with ofxNetwork on my macbook, and it works as long its local on my network, but when i try to connect to a server on a remote IP (for example the IP of my router in the world, 87.60.156.146) it just freezes during setup, even in the example file. I can ping all the IP adresses i have tried, and i have tracked down the freeze to be in the socket.h connect function. But i can’t see any more, and it doesnt give me any console messages…

Any help? Is it supposed to work on the internet?

Does your router have a firewall by any chance?

I don’t think so… And i asked rui here from forum also to try at his place, and he had the same problem…

yes it should work on the internet.

Maybe you are not forwarding the ports properly on the router and it is hanging waiting for the connection.

Do you have blocking turned on - on the client?
If so try turning blocking off and see what happens.

Also did you apply the fixes for ofxThread applied - you can get them here:
http://www.openframeworks.cc/downloads/-…-hanges.zip

Theo

Hey Theo

Got the updates already…

The router is set to forward all ports to my computer (DMZ’ed), and no firewall…

Have you tried to use it over internet?

Okay, it was my f***ing ISP that does’nt allow me to do this… Got it working on a friends server :slight_smile: