ofxLeapMotion / WTF ? ----> [ RESOLVED ]


#1

Hello everyone

I’receive today my LeapMotion, it’s amazing!!! Working great, and everything… But not in OF… I’m using the example that you can find in “ofxLeapMotion - master”.

I do nothing exept running it, the app open… But no leapMotion tracking in it… ? Does someone have the same problem with it? Or a solution ?

Thank you and have a nice day, and for people that have their LeapMotion… “Welcome to a whole new world” (that’s the inscription in the box) ^^


#2

Same here: I just received my camera, tested Theo’s addon and nothing happened. maybe it’s just a matter of updating the SDK version.
Unfortunately tomorrow I’m leaving and I’ll be away from my desk for a few days; as soon as I’m back next week I’ll spend some time trying to fix the addon :slight_smile:


#3

Thank you, don’t forget me, “you are our only hope” ^^

and if someone else have an idea too, i’m ready to listen and learn!


#4

Have you tried replacing the files in : ofxLeapMotion\libs by the ones in the last version of the Leap SDK ?

I went through that process a month ago and I think it fixed it.


#5

I haven’t used this in a while, but make sure that the leap application is running before you launch the OF app.


#6

RESOLVED !!!

Exactly, you just have to replace the file located in: _ofxLeapMotion/libs/lib/osx/libLeap.dylib _
by the one that is located on the SDK in: lib/libc++ !!!

And it’s working like a roll’s royce !!! Thank to you so much haha !!


#7

does someone know how i do to keep the vector of the fingertrails, i’m trying to make a drawing app, but i want to keep the vector

:frowning:


#8

For the shake of updating this topic, I recently had problems for detecting Leap Motion from the ofApp in Ubuntu 16. It turned out that it was not properly installed. So I downloaded the last Leap Motion installation kit for linux. However sudo dpkg --install Leap-*-x86.deb could not be properly installed. So I found this link that solved the installation problem. I copy the steps here:

$ sudo nano /lib/systemd/system/leapd.service
$ sudo ln -s /lib/systemd/system/leapd.service /etc/systemd/system/leapd.service
$ sudo systemctl daemon-reload
$ sudo dpkg --install Leap-2.3.1+31549-x64.deb

The leapd.service file:

[Unit]
Description=LeapMotion Daemon
After=syslog.target

[Service]
Type=simple
ExecStart=/usr/sbin/leapd

[Install]
WantedBy=multi-user.target