ofxKinectExample not Connecting

I had this posted in the Beginner’s board but maybe it belongs here. I’ve deleted it from that board and am trying here, instead.

I built the ofxKinectExample and I get the following errors when I run it:

  
OF: OF_LOG_VERBOSE: ofxKinect: Context inited  
OF: OF_LOG_VERBOSE: ofxKinect: 1 device found  
OF: OF_LOG_VERBOSE:     id: 0 serial: A00367A10333046A  
send_cmd: Bad magic 00 b4  
freenect_fetch_zero_plane_info: send_cmd read -1 bytes (expected 322)  
freenect_camera_init(): Failed to fetch zero plane info for device  
OF: OF_LOG_ERROR: ofxKinect: Could not open device 0  
OF: OF_LOG_WARNING: ofxKinect: Device -1 isn't delivering data, reconnecting tries: 1  
Could not claim interface on motor: -6  
OF: OF_LOG_ERROR: ofxKinect: Could not open device 0  
OF: OF_LOG_WARNING: ofxKinect: Device -1 isn't delivering data, reconnecting tries: 2  
Could not claim interface on motor: -6  
OF: OF_LOG_ERROR: ofxKinect: Could not open device 0  
OF: OF_LOG_WARNING: ofxKinect: Device -1 isn't delivering data, reconnecting tries: 3  
Could not claim interface on motor: -6  
OF: OF_LOG_ERROR: ofxKinect: Could not open device 0  
OF: OF_LOG_WARNING: ofxKinect: Device -1 isn't delivering data, reconnecting tries: 4  
Could not claim interface on motor: -6  
OF: OF_LOG_ERROR: ofxKinect: Could not open device 0  
OF: OF_LOG_WARNING: ofxKinect: Device -1 isn't delivering data, reconnecting tries: 5  
Could not claim interface on motor: -6  
OF: OF_LOG_ERROR: ofxKinect: Could not open device 0  
  

I am on 64-bit Ubuntu and I’ve done all of the setup for the Kinect necessary to run the freenect-demos as a user (added udev rule, installed freenect drivers and demos, installed libusb-1.0) and am running CB as root. config.make has USER_LIBS = -lusb-1.0 in it, too.

Any help is appreciated. Thanks.