ofxKinect Xcode 7 Build Failed - error in usb_libusb10.c


Brand new to oF, trying to build an otherwise empty project, with the ofxKinect addon installed.

ElCapitan, Xcode 7.3.1, oF 0.9.3_osx_release

Build fails, with error - incomplete definition of type 'struct libusb_config_descriptor’

In line - retval = config->bNumInterfaces;

From method:

FN_INTERNAL int fnusb_num_interfaces(fnusb_dev dev) {
int retval = 0;
int res;
d = libusb_get_device(dev->dev);
struct libusb_config_descriptor* config;
res = libusb_get_active_config_descriptor(d, &config);
if (res < 0) // Something went wrong
return res;
retval = config->bNumInterfaces;
return retval;

Google doesn’t appear to have any mention, nor ofxKinect @ Github. Any light shining would be great, thanks!

Hey, I’ve got almost the exact same specs as you El Capitan, Xcode 7.3.1, OF 0.9.2 and I plugged in a kinect and it worked with the example for ofxKinect (examples/addons/kinectExample). My kinect is model number 1414. Perhaps this is the essential difference? There are some nuances to working with the different models, so it would be helpful to know which one you have.

I’ve noticed similar posts on the forum about the kinect example not working on El Capitan. Perhaps these problems are related…

A potential work around might be to use synapse + osc. I downloaded synapse and tried it out and it worked for me, but there is clearly something different about our setups.

Good luck!

Never mind about it working on my computer. I ran it again and realized that it only runs for about a minute and then the image freezes.

[verbose] ofxKinect: context inited
[verbose] ofxKinect: 1 device found
[verbose] ofxKinect:     id: 0 serial: B00366701782043B
[notice ] sensor-emitter dist: 7.5cm
[notice ] sensor-camera dist:  2.4cm
[notice ] zero plane pixel size: 0.1042mm
[notice ] zero plane dist: 120mm
[verbose] ofxKinect: device 0 B00366701782043B connection opened
Got cancelled transfer, but we didn't request it - device disconnected?
USB camera marked dead, stopping streams
send_cmd: Output control transfer failed (-99)
write_register: send_cmd() returned -99

This problem also happens on Synapse, so it must not be just related to OF. While setting up virtual boxes for linux on El Capitan I ran into many problems with using usb devices that were not so problematic with earlier operating systems. Perhaps it is related to changes in how El Capitan handles usb devices?