ofxKinect starts but w/ error Isochronous transfer error: 1


First time posting to the ofx forum after being impressed with many libraries.

I am able to get Processing and my kinect to talk fine on OS X 10.6.5 but ran into issues on ofxKinect inside xcode 3.2.5. The ofxKinect is fresh off github today, 2010/12/12.

The app compiles and runs, it appears that the kinect cameras update for a few frames within the first second but then I see Isochronous transfer error: 1 in the console. The app continues to run with the accelerometer, threshold and tilt functions working normally. Just no camera updates.

I’m wondering, but not sure, could the existing libusb and libfreenects that were installed for the Processing sketch be affecting ofxKinect?

Appreciate any thoughts or ideas on troubleshooting.

I am having the same exact problem. Glad I found this thread. Any help would be greatly appreciated.

i ran into some issues when pushing the cpu pretty hard with threads. I ended up commenting out some of the accelerometer stuff and that seemed to help.

you can see the full-discussion-here

Ok, I commented out a line in the file ofxKinect.cpp in the function ofxKinect::threadedFunction().


This fixed the problem, but I am curious to understand why. Thanks for your help. :slight_smile:

Actually, this fixes the problem only temporarily. After about 30 seconds everything freezes again. Not sure what to do.

Last night I tried ofxKinect on a 2nd more modern MacBook Pro, this one is faster than my first machine and the code ran just fine, no camera stalling. On the first machine I also commented out all extra functionality including the sleep call.

Not sure if I will try ofxKinect again on the slower machine but the slower machine can run the Processing libraries fine, maybe less threading in the Ps library?

Good luck everyone

hi there,

just posted a message in another topic about issues with ofxKinect, includes a dirty hack that prevents the program from stalling: