ofxKinect recording

Hi!

I’m running ofxKinect using OF 0062 and VS2010.
The example runs, but when I try to record the file, I cannot find where it is saved.

The “recording.dat” file from the example doesn’t show up anywhere, even if I make the path absolute. Strange thing is that if I run the example for a second time and start playback immediately, it finds the file that I recorded previously, so it IS saved somewhere… ???

It should be loading and saving in the app’s data folder.

But it doesn’t. If I try to record with the example, it gives the following error in the console:

Could not claim interface on camera: -99
OF_ERROR: ofxKinect: Could not open device

The error probably means that the freenect_open_device() call made in stopPlayback() fails.

The file is not created and the playback does not work either.

If I change to an absolute path and remove the stopPlayback() call from the startRecording() method, I still can’t find the file but the replay works:

  
kinectRecorder.init(ofToDataPath("C:\tmp\recording.dat", true));  
...  
kinectPlayer.setup(ofToDataPath("C:\tmp\recording.dat", true), true);  

  
void ofxKinectRecorder::init(const string & filename){  
	f = fopen(ofToDataPath(filename).c_str(),"wb");  
}  

The problem is that the f is null… I do have permissions to write. Any ideas?

Edit: Found it… it was looking for ‘app/data/filename’ instead of ‘app/bin/data/filename’, since the data directory didn’t exist, the file couldn’t write. Problem solved, thx danomatika.