ofxKinect doesn't compile on 007 linux64 ( MOVED )

What build are you using for linux64 that works with the current github? I’d love to use ofxKinect + the easy VBO stuff in 007

the linux64 version in github is working, but only with makefiles. i’ll update the codeblocks projects soon

I have tried the experimental and regular build from the ofxKinect github against the current OF github and I get all sorts of compile errors.

I’ll try again later and post specifics.

I can get the regular build to compile with OF062 just fine.

oh, sorry i thought you meant the same OF not ofxKinect. haven’t tried in a while but if you copy any of the new makefiles, have ofxKinect in addons and add an addons.make file to your project with a line:


it should work.

src/testApp.h:34: error: cannot declare field ‘testApp::kinectPlayer’ to be of abstract type ‘ofxKinectPlayer’  
../../../addons/ofxKinect/src/ofxKinectPlayer.h:15: note:   because the following virtual functions are pure within ‘ofxKinectPlayer’:  

This is with latest github. Latest ofxKinect (build and experimental) with the “example” directory from the ofxKinect download dragged to the apps/examples directory. A new makefile used.

I also just took the ‘src’ directory from the ofxKinect example and put it in empty example with the addons.make file present and get the same error.

will take a look… btw i moved the posts since it was getting off-topic

Thanks for looking into it. 007 is really great!

Any idea?

add the following to ofxKinectPlayer.h
ofPixelsRef getPixelsRef();

and the following to ofxKinectPlayer.cpp
ofPixelsRef ofxKinectPlayer::getPixelsRef() {


This virtual (abstract) function had to be overridden.

I’ll test this out tomorrow! Thanks!

I’m still having this problem with XCode and latest git oF unstable / ofxKinect unstable