OfxKinect addons doesn't linking libusb0.dll

#1

Hi everybody ,
I want to use an XBOX360 KINECT with OF , so i tried the kinectExample.
I installed the freenect drivers with Zadig , and they are efficiently contained in ofxKinect folder
( I’ve got xbox nui audio , camera and motor in libfreenect/platform/windows/inf )
I’m running the sketch from VS 2015 on Windows10 , tried also with VS2013 but same result:
The sketch is compiling but when it starts I’ve got the error message :
“The program can’t start because libusb0.dll is missing from your computer. Try reinstalling the program to fix this problem.”
But libusb0.dll is already here in the OfxKinect folder , and the kinectExample is calling OfxKinect addon .
I tried to install libfreenect drivers from this topic


I’ve got some troubles to install with cmake the libusb used by libfreenect, but the libusb0.dll is existing in the
libfreenect folder, contained in OfxKinect addon folder.
Any ideas ?

Thnaks for your support :slightly_smiling:

#2

this:

if you get the dll
The drivers are not installed, make sure you uninstal everything from device manager and point to 64bit drivers (IN THE INF FOLDER) if you are on 64 bit- by using Zadiq,

1 Like
#3

Yes, I just read your topic
I installed XBox NUI Camera with Zadig to libusbK driver ,
and XBox NUI Motor + XBox NUIAudio under Universal serail bus device ( winUSB ).
Now I got : “The application was unable to start correctly (0xc000007b). Click OK to lcose the application.”
What you mean by point to 64bit drivers ? Point them in the Device Manager ? Thanks for your explanations !!!

#4

I tried to update XBox Camera driver to the platform/inf/ driver folder but I got this error message

#5

no point them from the Z app, the device manager doesn’t work anymore

click on advance mode and point from the Z app to the appropriate INF folder

#6

Hmmmm … Now it 's working but I got a driver error on the motor …

#7

ok you are in a good road, this means you have windows drivers conflicting with the correct.

restart, go to device manager uninstall the 3 drivers & also click delete and try again to just run the app.

#8

Ok, Solved by replacing the XBox NUI motor driver under the libusbK with zadig . THX for your help you roxxxx

#9

awesome! :beers:

1 Like
#10

Dear kkkkkkkk,
i have read through your frusturation and victory, such a road :slight_smile:
I am having similar troubles and had a question for starters. When you say, download libfreenect inf components, do you mean following this here: https://openkinect.org/wiki/Getting_Started#Windows
Because it suggests to download the libusb-win32, which you condemn then…

I am rather confused and would really much appreciate your help. Also, working on the installation part since 2 months… :frowning:
Bests,

#11

What i remember is i used Zadig to install easily the USB driver libusb ( it was on Windows 10 )

#12

thanks for your quick reply.

I am not sure if i am doing everything right.
The libfreenect library is already in lib in ofxKinect addon. Do i still need to download it?
From 0 i did these:
1-install Visual Studio 2015
2-download openframeworks
3-link the two
4-download zadiq
5-go offline
6-plug kinect and install the drivers in zadiq

in this line, i didn’t do these: https://openkinect.org/wiki/Getting_Started#Windows
Because libfreenect is already there (however the inf folder was empty before).
Am i being ridiculous?
Do i have to download libfreenect and all the dependencies or is it already included in new version of OF?

#13

I think my issue is that, i do not know how to do this:
“Solved by replacing the XBox NUI motor driver under the libusbK with zadig”

I do not now how to replace a driver where with zadiq. Could you help me on this?

#14

i reinstalled the drivers using zadiq selecting the relevant folders in inf folder of libfreenect. Than compiled the kinect example. First only the color camera worked but now it looks like this:

Will the cursor stop turning and will it ever compile correctly?
:frowning:

#15

Could someone fix the problem? Having similar problem here ! I can´t even install the drivers that are on the ofxkinect folder.

It says that “drivers up to date” when I place the folder of the drivers and it prompts :"The system cannot find the file specified " when i select the particular .inf file.

Any ideas or help?

i´ve tryed finding the folder where windows takes the drivers with no succes. Thought, kinect works relative well in processing.

#16

SOLVE IT !

I´ve found the solution in the “REAME.MD” file in the ofxkinect folder :

"The easiest way to add the drivers is to use the Free USB Driver tool: http://zadig.akeo.ie/
Select your Xbox Camera, Xbox Audio and Xbox Motor in the drop down and then select the libusb-win32( v1.2.6.0 ) driver from the driver menu and click install. (you will need to do this three times, once for the camera,then motor, then audio ). "

It works !

#17

0- Download Zadiq app: http://zadig.akeo.ie and open it (as admin)
1- Go offline
2- Plug Kinect
3- Go to Device Manager in your computer
4- Uninstall all of the libusbK drivers if there are still any that are installed automatically
5- In Zadiq click “list all devices” and “advanced mode” under options menu
6- click the folder icon next to driver and select the folder openFrameworks\addons\ofxKinect\libs\libfreenect\platform\windows\inf
7- repeat the steps 7.1 to 7.3 for Xbox motor, camera and audio
7.1- From the list of devices drop down menu select Xbox Motor NUI
7.2- In the driver list to be replaced to (right side of the green arrow) select “libusb-win32 (v1.2.6.0)”
7.3- Click “Reinstall driver”
DONE!

#18

thumbs up

#19

Fix the missing error of dll files .Find help for installation of libusb0.dll missing files it would be corrupted or invalid saved in any other unwanted folders