ofxHttpServer

hi all

during the development of pierre’s grand mutual smiles project:

http://www.80plus1.org/projects/grand-mutual-smiles

we needed to transfer images between oF apps. at first the idea was to use an external http server + the ofxHttpUtils or a script to send the images from one app to the other. in the end we’ve used a library called microhttpd that converts the oF app into an http server itself.

here’s an addon for that library that allows to serve plain files from the file system or create custom responses using and ofEvent that is called whenever a new request arrive.

it can attend get and post requests and with post, it can also receive files that are saved to a folder configured during the setup of the server.

in the example the server works in the port 8888 so to test it run the app and from a browser connect to:

http://localhost:8888/index.html

there are 2 options:

  • see the screen of the app as a web page that autorefresh. you should have the app in the foreground for this to actually work, if not the draw function is not going to be called.

  • post an image file: a web form will be shown where you can enter a name and an image file that will be sent and shown in the oF app.

the addon uses the microhttpd library, in the zip there’s versions for linux, linux64 and windows, don’t have a mac to compile it right now.

ofxHttpServer.zip

Here’s micro_httpd compiled for OSX. Thanks for the addon!

osx_libmicrohttpda.zip

Wow. Very nice, guys! Now to start making PHP/CGI work with it, and start pushing C++ into the formerly Java- and M$.NET-dominated territory of Web Applications! :mrgreen:

Hello!

I’m sorry, but on OS X I get some linker errors, complaining that some _MHD_ functions, all referenced from the ofxHttpd addon, could not be found.
I made a subfolder in libs/microhttpd/lib called osx. I added the microhttpd for osx posted from joshuajnoble into the lib-subfolder. Then I added the addon as usual to my project. Did I forget anything?

Thanks,
Gestalt

you need to add the library to the linker settings of your project. don’t remember exactly how you configure this in xcode though.

I thought this gets done automatically when adding an addon to Xcode (e.g. when adding openCv addon, i don’t have to add anything in my project/linker settings). Can anybody tell me, how to do that?

yes, opencv is added in every addon example so you don’t need to add it. i think it has to be in project > settings > linker > other options

and there add

…/…/…/addons/ofxHttpServer/libs/microhttpd/osx/libmicrohttpd.a

but if any xcode user can confirm it

LARGE POST FIELD BUG

I discovered a bug in the post field code. if you have a post field that is large (ie greater than 500 characters) the value in the response.fields will only contain the end of the value.

Example:
data=REALLYLONG ~<500>~ DATAVALUE

value should start with:
REALLYLONG…

instead it starts with
DATAVALUE

This is because large fields are broken up into smaller parts but the ofxHTTPServer code does not handle that.

To fix the situation, replace the if block at line 108 with:

  
if(!filename){  
			char * aux_data = new char[off+size+1];  
			memset(aux_data,0,size+1);  
			if(off > 0)  
				memcpy(aux_data,con_info->fields[key].c_str(),off);  
			  
			memcpy(aux_data+off*sizeof(char),data,size);  
			con_info->fields[key] = aux_data;  
		}  

perfect addon :wink: … need it for the exactly same task - transfering images between OF and another app.

thank you very much for this!

ok, also have problems with linking the library in xcode 3.2.1 – can’t find “project > settings > linker > other options”
any help would be appreciated.

edit: seems I have found the problem - the compiler throws a error: “/Users/m9dfukc/Documents/Openframeworks/of_preRelease_v0061_osxSL_FAT/addons/ofxHttpServer/libs/microhttpd/lib/linux/libmicrohttpd.a, file is not of required architecture”

… seems to be root of the problem. I will try to compile the microhttp lib for myself.

thanks
m9d

haven’t used it very much but i’m almost sure that in xcode youcan just drop the library in your project and it will work.

@arturo

yeah, that’s what i did … seems to be a different problem (see edit of my previous post).

thanks

yes, you’re adding the linux library, you need the osx one. can’t remember if it’s in the package, if not joshua posted it some posts above ; )

hi arturo - I added the osx one, not the linux lib (downloaded it from joshua) … also compiled it for myself (took the actual lib from here: http://www.gnu.org/software/libmicrohttpd/ ) - still getting this mysterious warning message – now: “ld: warning: in /Developer/SDKs/MacOSX10.5.sdk/usr/local/lib/libmicrohttpd.dylib, file is not of required architecture” … something I’m doing wrong

sorry for my stupidy :oops:

… will try it again with joshuas version

edit: note to myself: learn the differences between dynamic and static libraries ; )

ok,

very sorry for spamming but I still can’ get it up running - and I really don’t know what I’m doing wrong … maybe my lack of knowledge.

my problem:

installed you library, added joshuas compiled osx lib, removed the linux and windows ones.

running into a compiler error stating that "_MHD_… " can’t be referenced from ofxHTTPServer.
also getting a waring “in /Users/m9dfukc/Documents/Openframeworks/of_preRelease_v0061_osxSL_FAT/addons/ofxHttpServer/libs/microhttpd/lib/osx/libmicrohttpd.a, file is not of required architecture”

already tried to compile the libmicrohttpd for myself, but that did’t change anything.
tips/help would be really appreciated - won’t burn more and more in fixing a (hopefully simple) linker error (actually the most irritating part of c++ for me :wink:

by the way, I’m on a macbook pro, osx snow leopard, of 061 and xcode 3.2.1

thanks in advance
m9d

got it compiled now.

compiled the libmicrohttpd once again with the explicit arch=“i386” option. … it’s still a dynlib, have to research now how to create static libraries before I can post the file here.

another thing is - it’s works now but crashes with a runtime error on “terminate called after throwing an instance of ‘std::out_of_range’” – comming from ofxHttpServer.cpp line 181 - “uploadDir = ofToDataPath(”",true);" … did the behavior of ofToDataPath() changed since the last version?! (note to myself: check the changelog before asking thumb questions)

edit: for the ofToDataPath bug have a look here:http://forum.openframeworks.cc/t/oftodatapath-in-061—no-abs-paths/3091/0

cheers
m9d

ok,

hopefully the last entry under this topic (at least from me :wink:
m9d

libmicrohttpd.a.zip

m9dfukc, thank you! The out of range problem is the same one I was having. Thanks a lot for the fix.

Finally get it working, thanks m9dfukc!

Problem:

I have a client that sends one image to the server. On the server that images is processed to extract SURF points and other stuff and by the end I want to send a response to the client (xml saying what videos the image that was sent was found on).

  
  
void testApp::postRequest(ofxHTTPServerResponse & response){  
	if ( response.url=="/sendImage.of" ) {  
		extractSURF( response.uploadedFiles[0] );  
		response.response=searchImage( response.uploadedFiles[0] );  
	}  
}  

When the extractSURF is called, the image is on the server filesystem, until here no prob. When i try to load it on extractSURF,

  
  
ofImage *uploadedImage = new ofImage();  
	//uploadedImage->setUseTexture(false);  
	uploadedImage->loadImage( "upload/" + imageFilename );  

I get an error on the allocate, which a problem may be

  
  
if (myPixels.bAllocated == true && bUseTexture == true){  
		tex.allocate(myPixels.width, myPixels.height, myPixels.glDataType);  

on the glDataType. If I uncommented the setUseTextute(false), I don’t get any error, however I can’t call later on the cvExtractSURF.

Question:

  • If I try to access that image, for example on a second run of the application, I load it on testApp::setup and draw it, no problem. Why I can’t do the same on postRequest when I receive the image?

ofxHttpServer runs in it’s own thread, so you cannot use textures in the image as opengl is not thread safe and that will probably make your app crash.

don’t know why though, you cannot call cvExtractSURF as that should only use the pixel information, not the textures. what problem are you having when calling this function?