ofxGUI troubles

Hello, I hate to return to the forums so soon after posting my previous question, however I have been having some trouble with the openframeworks ofxgui addon in both 0.11.0 and 0.11.1.

Basically I have the following types in global arrays:

ofxPanel lump_makelump_panel[2];
ofxLabel lump_makelump_label[6];
ofxTextField lump_makelump_textbox[4];
ofxToggle lump_makelump_agreement;

and then the panels are setup and added to using a one time called function controlled via a bool:

lump_makelump_panel[0].setup();
	lump_makelump_panel[1].setup();
	lump_makelump_panel[0].add(lump_makelump_textbox[0].setup("Enter Lump Name","t"));
	lump_makelump_panel[0].add(lump_makelump_label[0].setup("Note", "Name must include the word: lump"));
	lump_makelump_panel[0].add(lump_makelump_label[1].setup("Also Note", "Name cannot have spaces or special characters"));
	lump_makelump_panel[0].add(lump_makelump_label[2].setup("Example Names", "Vixlump Lumpared DarthLump 123lump5"));
	lump_makelump_panel[0].add(lump_makelump_textbox[1].setup("Enter Valid Email", "t"));
	lump_makelump_panel[0].add(lump_makelump_label[3].setup("Note", "Email is used for account recovery only"));
	lump_makelump_panel[1].add(lump_makelump_textbox[2].setup("Enter Password", "t"));
	lump_makelump_panel[1].add(lump_makelump_label[4].setup("Note", "We devs beg thee to make something secure"));
	lump_makelump_panel[1].add(lump_makelump_textbox[3].setup("(Optional) 2nd Password", "t"));
	lump_makelump_panel[1].add(lump_makelump_agreement.setup("Do you agree to our terms of use?", false));
	lump_makelump_panel[1].add(lump_makelump_label[5].setup("Note", "Terms can be found at: lumpology.com/i-a-agree"));

before being drawn in my draw function with these two lines:

lump_makelump_panel[0].draw();
	lump_makelump_panel[1].draw();

And the result of that is this:

Im pretty sure im doing right, based on the docks however if anyone has anything to add, that would be much appreciated, I have tried a combination of things to fix the problem but none seem to work so far.

Hi, did you try isolating this? make a fresh new project and only put it it the gui code. Does it work?It works for me at least.
Also, you have both guis overlayed. you need to set the in a different position. you can do it via code.
The following will put both side by side.

lump_makelump_panel[1].setPosition(lump_makelump_panel[0].getShape().getTopRight());


You might have some other thing that is affecting the rendering of the gui, like Lights and depthTesting

Hmm, nope same problem again in the isolated case.
There should not be any depth testing, as it is a 2d game and was never enabled, same with lighting. (I tested with disable commands with the same result aswell)
I just reinstalled openframeworks the other day so that is not the problem

In the end I decided to go with a different better GUI, ofxGui is fine however so far coding wise ofxImGui seems far better.
Thanks for the help!