ofxGui is transparent and colorless in front of 3D scene

I need to draw a gui on top of a lit 3D scene. Whenever I do this, the gui becomes transparent and colorless. Any ideas of settings I might tweak to prevent this?

    guiLight.enable();
    ofDisableDepthTest();
    ofDisableSeparateSpecularLight();
    gui.draw();
    bulb1.drawGui();
    bulb2.drawGui();
    ofEnableSeparateSpecularLight();
    ofEnableDepthTest();
    guiLight.disable();

you should disable lighting too

All lights are disabled and the problem persists.

    bulb2.disable();
    bulb1.disable();
    guiLight.enable();
    ofDisableDepthTest();
    ofDisableSeparateSpecularLight();
    gui.draw();
    bulb1.drawGui();
    bulb2.drawGui();
    ofEnableSeparateSpecularLight();
    ofEnableDepthTest();
    guiLight.disable();
    bulb2.enable();
    bulb1.enable();

isn’t guiLight a light?

guiLight.enable()

Ha! Indeed, fair point. But the problem gets much worse without that light. See below:

I can hardly see the gui at all with out it.

oh, yeah, you should disable lighting completely otherwise it’ll try to render things using lighting. just use ofDisableLighting() / ofEnableLighting() instead of disabling the lights individually