ofxEdsdk with Xcode 7 & OF0.9.0rc2 - ld: framework not found EDSDK

Hello all,

I feel really stupid. I’ve spent 3 hours now trying to figure this out and no idea. I’ve tried multiple branches of the addon and searching high and low - nothing that has solved it. I’m thinking its something weird with Xcode 7 as there have been a couple of other articles online that I have seen with similar issues but nothing they have done to fix it has helped.

Has anyone else encountered this or know of anything to look for? I’ve included the path in the framework search path…

Thanks, Ryan

And to also add to this, I have an existing project that built just fine a few months ago on a pre RC version of OF 0.9.0 that no longer works.

Figured this out… Helps to use the 64bit vs 32bit version and build with that…

1 Like

Hey @ryanww,

I’m having a same problem using a nightly build of openframeworks from a week ago. I installed ofxEDSDK and having the same linker problem while compiling.
I tried linking to the 64-bit version of SDK as well as the 32-bit version, all with the same error. You have any suggestion? I used the 3.2 Version of EDSDK.

Sorry for the late reply…

To be honest, I don’t remember… Did you figure this out? Otherwise, I can probably send you the Xcode file for that project and you can take a look a the linking for the libraries.

No, I didn’t figure it out yet.

Otherwise, I can probably send you the Xcode file for that project and you can take a look a the linking for the libraries.

Yeah, that would be nice!

I’m going to PM you a link for the project. Had to remove the source code for licensing reasons, but the project file and EDSDK I used was in there. One thing I found is that it would just not want to connect to the camera and would crash the app on start so sometimes you just have to keep opening it until it finally connects and locks on to the camera.

Let me know if you still can’t get it and I can try to help out.

Your project works indeed. Thank you!
I compared it to my project file but I couldn’t find a significant difference to your file. Did you use the project creator creating the project or did you use some manual steps. I used the xCode addon to add ofxEDSDK. Perhaps that might be the reason.

hello ryanww. i am having the same problem…
can you please send me the files as well?
do u also have the windows version? i have tried both but no luck.


update

i am using xcode 7, with of0.9.3
after using project generator. link back the frameworks to the library and add to the library search path… i am able to compile the source… now looking at how to connect with the camera…


hello ryanwww, i wonder if you have the windows source to share… still i have no clue how it works…

Hey jingle,

I only have the mac source for a project I had worked on. There is an example in the folder which worked when I had tried it. But again, that was on Mac. I also haven’t tested it in a year which I know their SDK is significantly newer now… Hopefully fixes the random crashes with cameras.