ofxCGAL + Xcode 6.1.1?

Does anyone have the ofxCGAL + ofxOSXBoost libs working with Xcode 6.1.1?

I have the libraries etc correctly linked but the example won’t compile - a whole heap of semantic and parse issues kick off

S

Hey sam,

Having a look now… it should work… maybe something has broken with new ofxOSXBoost.

Hey Sam,

I’ve updated ofxOSXBoost to the latest Boost.
Also found some issues with the old example project file.

See my branch here for latest changes.


Be sure to checkout ofxOSXBoost again.

speedy work dan, thanks
have tried this - looks like the previous issues may be fixed but I’m now getting:

ld: warning: directory not found for option '-L/Users/sammcelhinney/Documents/*OPENFRAMEWORKS/apps/pointApps/CGAL_example/../../../addons/ofxOSXBoost/libs/boost/lib/osx'
ld: library not found for -lgmpxx
clang: error: linker command failed with exit code 1 (use -v to see invocation)

looking at the ofxOSXBoost addon I’ve taken from your github, it does seem to be missing the ofxOSXBoost/libs/boost/lib/osx directory - am I overlooking something?

S

Oh thanks for pointing that out… it looks like the lib was ignored and wasn’t uploaded!
Fixing now!

whoop whoop, successful running on OSX_10.10 and Xcode 6.1.1

one v minor point - on your ofxCGAL github your last two lines should be:

ofxCGAL/libs/CGAL/lib/osx/
ofxCGAL/libs/CGAL/lib/osx/CGAL

at the mo they are the same line :wink:

thanks for the assist
S

one last thing…I’m trying to add those add-ons to put extra functionality into a previous app of my own. All done and linked correctly I think.
But on running this app now flags the original semantics errors. Are there changes/tweaks that you made to your example that I might need to follow through?

S

Thanks! I’ve Updated the readme for ofxCGAL

Ah… maybe make sure you are building against C++98.

So Under the the “C++ Language Dialect” set to C++98
Or search for the “CLANG_CXX_LANGUAGE_STANDARD”

yeah that might be the thing… anyways I ported the other way, cleaned out the example as a template and then re-added my own source files. Who knows what the problem was, but it works well now.

Thanks for the help, much appreciated
S

Hi guys,

The example file does work (I had to fiddle with it as well) but I’ve been trying to get it to work from scratch for a few days now but I keep running into this error:

…/of_v0.8.4_osx_release/addons/ofxCGAL/libs/CGAL/include/CGAL/gmp.h:30:10: ‘gmp.h’ file not found with include; use “quotes” instead

and this one:
…/of_v0.8.4_osx_release/addons/ofxCGAL/libs/CGAL/include/mpfr.h:39:10: ‘gmp.h’ file not found

I’ve set all the headers, library paths (including boost) but I can’t get rid of this error. (even with C++ dialect set to c++98.
I’ve been looking into gmp too. All of the settings, paths, etc… but I just can’t see what’s in front of me I guess.

Just wanted to add that I very much appreciate the work that has been put into the creation and maintaining this add-on.

Have you taken a look at re-linking the link binary with libraries in Build Phases? I think I had this problem but may have solved it by doing this.

Hi all,

I have some issues with CGAL this week but finally got it working.
If this helps somebody:

cheers :slight_smile: