ofxBullet v2.0, bullet lib error compiling on Code::Blocks 10.05, Ubuntu 12.04

I downloaded and extracted ofxBullet v2.0 from GitHub and put the folder into the addons folder.
Then I created an app with the ofxBullet addon, and added #include "ofxBullet.h" to testApp.h, then tried to build the project.

I’m using oF v0.8.0, Code::Blocks 10.05 on Ubuntu 12.04.

Sure enough, I’ve got one error in
../../../addons/ofxBullet/libs/bullet2.8.1/include/BulletMultiThreaded/GpuSoftBodySolvers/DX11/btSoftBodySolverBuffer_DX11.h, line 19, fatal error: windows.h: No such file or directory.

There’s this piece of code in that header file:
// DX11 support
#include <windows.h>
#include <crtdbg.h>
#include <d3d11.h>
#include <d3dx11.h>
#include <d3dcompiler.h>

It seems that the error belongs to the Bullet Physics source, which tried to include a bunch of windows sources.

What should I do to get it running in Ubuntu? Is it possible to get a linux version of Bullet and manually linking it with ofxBullet? (not sure if there’s a linux version, and even if there is, I don’t really know how to link it with ofxBullet)

I am stuck on the same thing here.
From random Google searches it seems i could try disabling multithreading for bullet but as a very inexperienced compiler i don’t know how.
I would love to see a solution to this.

–EDIT-- update
I managed to use latest release version (1.0) of ofxBullet to compile an empty app.


Haven’t run anything working with it yet though it should work just fine I guess.

Hello,

I am facing the same issue: “window.h file missing”.
I am just trying to run the OfBullet examples on mac OS 10.10.1 with the latest ofxBullet 2.0 from @NickHardeman.
How can I bypass this missing file?
Thank you!