ofxAudioAnalyzer - Update

You could also try my pull request, which fixed issues I was having using 0.9.8 and ofxAudioAnalyzer on a mac.

@clem Yeah, i’m using leoz version.

I tried the sugestions and i’m getting other errors.
For this part n line 56: #define AUDIODECODER_OK 0 is alredy there send you a screenshot.
I added the addon using the ofPlugin
Thanks.

You have this problem when adding the addon to a new preoject only?
The addon examples compile ok?

If it’s only in new projects, try adding the addons with the Project Generator (https://github.com/leozimmerman/ofxAudioAnalyzer#usage)

Same problem using the project generator

Hi. I’m running on linux 64. I tried using the makefile to compile “example_emptyExample” but it seems to fail when linking. I get a bunch of lines like this:
/media/stuff/playground/openframeworks/of_v0.9.8_linux64_release/addons/obj/linux64/Release/ofxAudioAnalyzer/src/ofxAudioAnalyzerUnit.o: In function ofxAudioAnalyzerUnit::setup(int, int)': ofxAudioAnalyzerUnit.cpp:(.text+0x4f22): undefined reference toessentia::standard::Algorithm::input(std::__cxx11::basic_string<char, std::char_traits, std::allocator > const&)’

Any thoughts? I’m pretty sure I was able to use this library about a year ago, but I have since re-formatted my computer and am using a fresh openframeworks install.

OK I fixed it by recompiling essentia, and then swapping in the “libessentia.a” file.
It was necessary to use the lightweight version (wasn’t working until I read the notes for building essentia).
So I guess the answer was there the whole time… but maybe someone else will read this and feel encouraged.

I’ve just tested current master ofxAudioAnalyzer with last stable version of OF (0.9.8) and everything work fine for me, examples, audiodecoder, project generator.
I’m using OSX 10.11.6 and Xcode 8.1

Are you 0.9.8 stable version?

Hi, Thank you!

I am geeting >>No member named 'numMessages in ‘ofxPd’ <<
I have it included in my files and as an add on, pd and audioAnalyser examples work.

OFX .9.8_OSX 10.11.5 Xcode 8.0

Does anyone know if this addon can do VAD - voice activation detection?

Hello,
I’m trying to compile examples / empty project with the addons, but I can’t make it work.
I’m using ubuntu 16.04, and OF 0.10.0 . I compile examples or new project with makefile.
When I’m trying to build with the make, I have several errors (see images).
Do you have an idea of the problems ? Should I use one of the branches ?
Thank you in advance !!

Capture%20d%E2%80%99%C3%A9cran%20de%202018-12-27%2023-05-42|690x388

Have you checked this: https://github.com/leozimmerman/ofxAudioAnalyzer#audio-file-player ?

Thank you for your quick answer ! Well in fact, no I didn’t check this… So I deleted ofSoundPlayerExtended.* (I don’t this for my purpose).

And now I’m facing new errors ^^.
So here are the errors:


The errors translated in english is "need a dynamic relocalisation R_X86_64_32 may overflowing at the execution


The error in english: error: reference to “…” undefined.

So since it seems to be related, I’ve tried the following:

Add some flags in the config.make:

Moreover, I have followed (I think) all the instructions from essentia_compilation.md.

Do you have an idea ?

Best wishes for 2019 :slight_smile:

So did you compile new binaries for Essentia and fftw3 libraries? Maybe a new version of Essentia is needed for new Linux versions. Sorry, but I don’t use Linux on a daily basis so I won’t be able to review this soon.

Well, so I’ve install the newest version of Essentia and followed instructions (found here: https://github.com/MTG/essentia), still have the same problem.
I will continue to investigate, if I found something I will post it !
Thank you

Hi, I’m working on a project which requires chord detection and I’m trying to use the ofxAAMultiPitchKlapuriAlgorithm - how do I set this up? I’ve got the ofxAAPitchSalienceFunctionPeaksAlgorithm and ofxAAOneVectorOutputAlgorithm as pointers for the setup function, and the computing function is happening in update (which is also where I’m getting the pitches array). I’d really appreciate any help if anyones got this working already?

cheers :slight_smile:

hey, anybody running this addon/essentia on Windows?

I have the same question, but for M1. I’m building an app for an artist and I’ve spent hours trying to build essentia on a new mac mini but I haven’t found a way to make it work.

I updated the OS to the latest version, updated xcode, installed the xcode command line tools, used the --no-msse flag as suggested in essentia on M1 Macbook · Issue #1233 · MTG/essentia · GitHub but still fails. Then I found this brew recipe which does install essentia, but it doesn’t build the static .a library needed by ofxAudioAnalyzer. I tried tweaking the flags in the recipe with brew edit essentia but if I add --build-static it fails to build.

If anyone has the libessentia.a built for M1 I would be very happy to use it in the project.

@hamoid you could do the exclude arm64 hack as mentioned here Run ofxAudioAnalyzer in of_v0.11.2 MacOs 12.2.1 - #2 by zach

1 Like

Thank you very much! :man_dancing: :partying_face: So simple. I had somehow managed to build essentia, libsndfile and fftw3f on M1, but I guess compiling them 6 years after the original was producing binaries with incompatible APIs.
This solution allows me to continue with the project :slight_smile:

1 Like