ofxAssimpModelLoader problem

I am not able to see texture on my 3d model i exported into my openframeworks app.How can i see/enable it?
I am using of 0.8 on Osx 10.9
Here is my code:

void testApp::setup(){
model1.loadModel("Woola_OBJ.OBJ");
model1.enableTextures();
model1.enableColors();

}

void testApp::draw(){ 
model1.setPosition(500, 400, 0);
model1.drawFaces();
model1.setRotation(1, mouseX, 0, 1, 0);
}

Here are the pictures:
using photoshop->

using of ->

My second question is that i am not able to load a “.dae” file(s) with ofxAssimpModelLoader even though it supports loading Collada models.Is it a bug?

Update : got my answer on github for the 2nd question, had downloaded a bad file ,big mistake .

Do you have any lights in your scene and are they enabled?
If you are sure there is a texture in the model, sometimes call ofDisableArbTex() before calling loadModel helps.

@NickHardeman No I don’t have any lights in the scene . Putting ofDisableArbTex(); didn’t help :frowning:

Try putting an ofLight in there above the model. That way you will be able to get a better idea of the mesh.
Are you sure it has a texture? It just looks like a gray material in the photoshop screen shot.

Yeah the problem was solved with ofLight .Thanks !