ofxAssimpModelLoader issues

I have been working with ofxAssimpModelLoader a bit lately and I have noticed a few issues that I can’t seem to figure out. Our designer is building the models in Cinema4D r12. We have tried exporting with many different combinations of options selected. We have had the most success with exporting .x files. Some issues that we have not been able to resolve, but are working in the assimp examples:

1). Getting more than one mesh drawing, even using the assimp example that does this.
2). When scaling the models, the light of the model appears blown out.
3). Getting the materials for each object. We can’t seem to get them at all.

Not sure what the settings are that work best with this addon, but we can not figure them out. Any help would be greatly appreciated.

It sounds like your models are more complex than what I am doing but .3ds has been the most consistent with the mesh for me. The texture (just using one at the moment) doesn’t export correctly I am able to get the path from the console errors and rename/put it in the right place.

However almost everything I do is flipped upside down (.x included). Do you know of a way to make this consistent? I have been just translating -y but I would rather not if possible.

i am wondering these things as well. with assimp 07 on lion. i’m specifically looking for an export workflow in collada. i have looked on the assimp forum and vades forum and there isn’t much help in these regards. i realize that not all of collada is supported…

on the most basic level animating a cubes rotation exported as dae or collada out of maya works in preview app and loads into assimp 07 in lion. mesh animations and textures are all found but no animation is produced. interestingly enough the same model export works in snow leopard ? i have inspected the astro boy model and have set up what seems to be the equivalent but still no animations.

some things i have tried…

• re compile assimp framework
• bake animation
• bake simulation key frames
• bake xyz channels down to just the mesh. delete bones and effectors + history.
• set up multiple animation takes or clips etc…
• point key frame every vertex of mesh.
• normal skeleton - > bones - > IK -> skin animations. still nothing.
• baking just joints.

i have tried every combination of .dae .x and .3ds also have done my best at re implementing astro boy with the same names…

like i said I’m not sure if its a lion issue or not. i don’t understand why the developer of assimp or the creator of the models doesn’t say this is how i exported the demo models. its obvious astroboy was exported with maya 2008. i have choose that as a starting point but still no luck.

i have modified ofxASSIMP to name my faces so i can select them with the mouse. this works fine. again the simplest most basic export rotate a cube with 4 faces doesn’t work for me in lion but does in SL ?

it doesn’t matter what program. maya, c4d, blender, cheetah, etc… i would greatly appreciate any advice on how to export an animation in lion ?

@ jvcleave

make sure your textures are powers of 2 and square. 512 x 512 or 1024 X 1024 etc… that helped me out a bit. i have been primarily trying to get collada to work in lion on the simplest level. cube - > verts -> indices ->texture -> normals - > rotation animation. no luck. see if making a texture reference works. i attached my file texture to a blin materials color channel or diffusion channel and exported with relative file paths in collada

Thanks dust. I do have a texture working - all good there (like you said, I did have to make it 1024x1024).

What I am having an issue with is no matter how I rotate the mesh in the viewport in Cinema4D it gets placed upside down with ofxAssimpModelLoader.

3DModelLoaderExample loads and displays it correctly but I saw that uses model3DS which probably knows 3ds a little better?

@Nick

Could this be your issue with materials missing?

from:
http://assimp.sourceforge.net/lib-html/importer-notes.html

What will be loaded?
Mesh: Faces, Positions, Normals and one Uv pair. The Materialname will be used to load the material.

come to think about it my tests have been with a noisy texture. So my texture could be upside down and not noticed it as well. At first I was getting some glitches with a png texture but then I realized my texture wasn’t square. Could not tell you how to flip uvs in c4d kind of a noob with c4d. I have had the best luck with positioning uv coords when using nurb models. I’m going to figure this out. It’s like I can see the example models animating. Got to take a break wasted the last few days trying to figure this out. It’s like all I want is my button to act like a transformer and transform into my menu. I have not tried md2 or md5 yet. Looks like the author does provide some export workflow information in that link you posted that i must have over looked. Looks like I’m off to blender and ogre export land. Thanks. Once i figure this out i will post my method. I can’t be the only one having issues with loading animations in lion.

@jvcleave not sure, but our intern is doing all of the c4D work and she figured it out. I will try to get some more information from her and post our findings. We haven’t worked with animations yet, sounds tricky.

Haven’t tried it yet but doing some searching I found this. It is talking about working with .max files but it may be useful for .3ds as well

Converting Coordinate Systems (3DS Max->OpenGL)
http://www.gamedev.net/topic/209830-converting-coordinate-systems-3ds-max-gtopengl/

We put together a blog post based on the workflow Lauren and I developed to finish the game Follow This!.http://lab.arn.com/2011/10/follow-this/

The post outlines getting textures and multiple meshes from C4D to OF 007.
I know it’s a bit late, but hopefully someone will find this helpful.

Check out the post
http://lab.arn.com/2011/10/cinema-4d-to-openframeworks-workflow/