ofxAruco + ofAndroid for android studio: example error

My method to ofxAruco for android studio was as follows:

  1. Clone ofxAruco and ofxCv in addons folder.
  2. Copy files from ofxaruco/bin/data to bin/data folder of androidEmptyExample
  3. Update addons.make and include ofxOpenCv, ofxCv, ofxAruco.
  4. update main.cpp file and ofApp.h and cpp files as given in example.

make project is done successfully however when I try to run it I am faces with three errors.

  1. Error:(48, 30) error: ‘ofBitmapStringGetTextureRef’ was not declared in this scope
  2. Error:(56, 29) error: ‘class ofBaseVideoDraws’ has no member named ‘getPixelsRef’
  3. Error:(157, 1) A problem occurred evaluating project ‘:openFrameworksProject’. make failed with exit status 2

this is just because the addon hasn’t been updated to work with 0.9. you would just need to replace those functions with the correct ones now, i think you just need to drop the Ref suffix in both functions but not 100% sure. if you manage to fix it please send a pull request to the original repo or post exact solution here so i can fix it

Okay I have resolved the errors aparently.

ofBitmapStringGetTextureRef= ofTexture() see ofBitmapFont.h for reference
getPixelsRef= getPixels
But I said apparently, because I ran the example with flag useVideo= true, I can see on my mobile screen small section playing video of board. But markers detected is 0. And also rest of screen is empty. Can you tell me what default behaviour I should expect.

@muhammad_haris Worked for me, I changed the lines, printed out the board in the example bin folder and it was detected by my webcam. There’s the PR https://github.com/arturoc/ofxAruco/pull/12