ofxAruco broken?

Tried to install it, along with ofxCv (stable branch) and it throws lots errors because it’s looking for aruco-1.2.4 when the addon now has 1.3.0. This is on Mac.

On linux it thrown all sorts of errors about not finding headers of ofxCv. Any idea @arturo?

(using openFrameworks 0.9.8)

Thanks,

Theo

someone sent a PR recently to upgrade to 1.3 and add some new features so it might be related to that. the PR is here: https://github.com/arturoc/ofxAruco/pull/20 i’ve already contacted them in case they have any clue

thanks @arturo.

On the Linux front does it compile on your machine? I’m running linux mint with of 0.9.8 and stable ofxCV but it keeps saying it can’t find headers of ofxCV like this:
/home/theodoros/bin/of_v0.9.8_linux64_release/addons/ofxCv/libs/ofxCv/src/Calibration.cpp:1: error: ofxCv/Calibration.h: No such file or directory

Any clue? Could you compile it on linux?

i’ve only tried with master but it works there with a couple of fixes to update ofxCv for which i’ve already sent a PR to kyle

On my mac it works as well using the current master (OSX 10.11, XCode 7).
Could you describe the error on mac.

Hi both,
sorry for the late reply.
I managed to make it work on a Mac. It works fine. I started with a fresh example and it simply worked.

On linux I downloaded master and I get this error from @kylemcdonald’s code

 error: return-statement with a value, in function returning 'void' [-fpermissive]

I suspect @arturo these are the kinds of things you asked him to fix? X is more permissive. Linux complains about things like that and fails to compile.

Cheers both

yes i sent him a PR to fix this but it’s not merged yet. in linux i enabled a while ago a flag so not returning anything from a function is a hard error instead of a warning, i thought it was enabled on other platforms as well but i might be missing osx if it’s working there

Oh makes sense. What is that flag on linux @arturo and how do I enable? Any tips greatly appreciated :slight_smile:

Hi all,

I still have troubles making it on mac. Could you help with hints on how did you manage it to work?
Cmake complains at the very beginning, during configuration:
aruco.pc.in does not exist.
CMake Error at CMakeLists.txt:324 (configure_file):
configure_file Problem configuring file
and:
aruco-uninstalled.pc.in does not exist.
CMake Error at CMakeLists.txt:325 (configure_file):
configure_file Problem configuring file

(I’m an ageing dumb artist not a professional coder, so please forgive me, I’m about to “refurbish” an in interactive work I programmed more than 10 years ago using ARToolkit http://szmz.hu/visual_communication/visual_communication.html)

I greatly appreciate any help, it seems quite challenging to use such an elegant AR solution.

Thanks in advance: Zoltán Szegedy-Maszák