ofVideoGrabber draws only a black rectangle

Hi,

I have some trouble with the CameraExample. I tryed different -git dev of- versions, and working with ndk6 and sdk 2.2 on ubuntu. The grabber draws only a black rectangle with 0fps. Some build before I had 60fps, but also a black image.

In LogCat the camera seems to work fine… or not?
Some of my LogCat Messages:

V OF: Camera 0 facing: 0
V OF: Camera 1 facing: 1

E OMXCameraAdapter Initialize - Sensor 1 selected successfully
E - Preannouncement disabled successfully
D - IMX Component name: [IMX.TI.DUCATI1.VIDEO.CAMERA]

I OF: ofVideoGrabber: Camera initialized correctly"
E CameraHal: startPreview - Preview not started. Preview in progress flag set

Please let me know if you have any idea I can try…
Thanks in advance,
dan

Was this solved?
i have the same problem with my Nexus, any ideas?

Some devices seem to have problems with how the camera is initialized in OF, can you try substituting the videograber in ofxAndroid/ofAndroidLib/src/cc/openframeworks/ with the one i’ve attached and tell me if that solves the problem?

OFAndroidVideoGrabber.java.zip

I’m also having trouble with this. I tried downloading the file posted above as well as grabbing the most recent version from the developer branch, but the grabber is just never getting a new frame and I’m left with a black rectangle on screen.