ofSetBackgroundAuto flicker

I’m trying to draw with persistence from frame to frame, but instead this code will render every other ellipse each frame:

void testApp::setup() {  
	ofBackground(0, 0, 0);  
void testApp::draw() {  
		ofRandom(0, ofGetWidth()),  
		ofRandom(0, ofGetHeight()),  
		10, 10);  

That is, each frame alternates between displaying the ellipses drawn on even frames and those drawn on odd frames.

Is this a standard opengl thing I don’t know about, something weird with my video card, or…?

sounds like a graphics card bug. what is you graphics card? we’ve had this issue with either fullscreen or non fullscreen apps using setBackgroundAuto(false) on pc. I’m not sure why, but it’s some kind of buffering issue.

if you try changing fullscreen, does it help?

can you let us know the model of graphics card?

I’d like to try to debug it -


Thanks Zach – since you guessed it’s the video card, I dug through the control panel on the Quadro NVS 140M (in my Lenovo T61 Thinkpad + Vista) and narrowed it down to the antialiasing. It gives me four options: application-controlled, off, enhance the application setting, override the application setting. There is another option with 2x, 4x, 8xQ… that determines the detail of antialiasing.

The only mode that works (i.e., draws persistently) is “override the application settings”. Regardless of whether ofEnableSmoothing() or ofDisableSmoothing() is called, none of the other settings work. Even with “override”, there’s a weird bug of the first two frames not being persistent, but the remaining frames will be.

edit: Also, fullscreen/windowed doesn’t have an effect.

After installing the new drivers for the card, only fullscreen + override antialising works for accumulating things. Windowed + override antialiasing doesn’t help.


I recently updated to osx snow leopard (previous leopard) and now I’m experiencing the same behavior.

edit: using OF 0.061, macbook pro (not unibody), ati graphics card