ofSetBackgroundAuto(false) not working

I have updated to the latest release, but I’m having problem with the command ofSetBackgroundAuto(false); If I say ofSetBackgroundAuto(true), the program works, but I won’t get the trails I want. But if I set it to false, the window goes bananas, as shown in the picture below.


Without ofSetBackgroundAuto(false), how I want the program to look at start.


What I get with the command.

Please, any help would be appreciated.

I’m also getting erratic behaviour (glitches all over the screen) with ofSetBackgroundAuto(false); only on Windows (XP).
I’m getting this on of 0.057, 0.06 and 0.061.

hmm – curious because I thought we did fix this with 0.061 – in 0.06 and below it was a problem. In 0.061 it seems to work ok (although I remember that it can be wonky if you resize the window during the running of the app)

can you let me know what your graphics cards are? and can you experiment with vertical sync / enabling / disabling either in OF and in the preferences of the graphics card?

I was testing on XP / Parallels / MacBook Pro (non unibody) and my graphics card is nvidia.

if you can post up sample code too I’ll try it.

take care,
zach

It was working before I upgraded, but I’m not sure which version I had before.

I run Vista on a Mobile Intel® 4 Series Express Chipset Family.

I tried with an example project. I took polygonExample, and changed in main to run fullscreen and added ofSetBackground(false); in setup, and got the exactly same picture as I have linked.

downgraded to .06, now it works again. but thanks for the time, soon I will be ready to share my program =)

Hi Zach,

running of 0.061, the project runs fine on Mac OS and Linux with ofSetBackground(false).
On Windows XP the screen flickers a lot.
The machine is a MacBook white, GeForce 9400M running Windows on Bootcamp.

If you’d like to take a peek at the code, it’s bundled on the Quase-Cinema download at http://www.quasecinema.org (just set ofSetBackground(false) on the CB project). It’s easier to download the full project from there, because of the addons, project, demo movies… The site needs a registration; if it’s too much of a trouble, I can try to get the project tidy to post it here.

Thank you!

I tried all combinations of vertical sync on/off from of and from the graphic card. Same results.

I noticed some strange behavior from ofSetBackgroundAuto(false); as well. 8)

I recommend setting ofToggleFullscreen(); to a key and trying that on OF apps that are misbehaving on their background redraw. That’s what led me to my solution (the screen was offset the height of the titlebar).

C

Same here! it seems that the problem persists with the latest pre-release 0.07 + Win 7.
whenever I do ofSetBackgroundAuto(false); the background still refreshed on every frames. :’(