"ofSerial::listDevices" don't show /ttyACM ports

Hello, I’m trying to connect several arduinos from my computer. I was using PySerial which show me both ttys and ttyACM ports. But with ofSerial::listDevices method I couldn’t do that. When I run it i only show my ttys ports.

Here is my code :

#include "ofMain.h"
#include "ofApp.h"

ofSerial serial;

int main( ){



I’m using Ubuntu 14.04 with Code::Blocks.

@bakercp’s ofxSerial might be worth a look. I have used it with a Raspberry Pi to access an Ardiuno via /dev/ttyACM.*.

Yeah, try https://github.com/bakercp/ofxSerial. I just added cross platform serial listing. It should list /dev/ttyACM.*. If it doesn’t, let me know and I’ll make sure it does by day’s end :smile:

I added ttyACM support to the native ofSerial, but only for Raspberry Pi. That should probably be fixed in the core, but I’m putting all of my serial work into ofxSerial these days because I believe it’s a better cross platform solution.

P.S. Yeah, I’m pretty confident it will list ttyACM. Check here for the source.

P. P. S. Also, note that ofxIO is required.

BTW, I just went through and tested ofxSerial port listing and coms on windows and it all works in codeblocks, but there are some strange errors I’m still getting in VS2012 in the list ports functions. It has something to do with strings … but someone with more experience deciphering VS errors will have to take a look at that one :smile:

I have just tried in Ubuntu with Code::Blocks and it works. Thank you. I think it should be added to ofSerial also.

But in ofxSerial listDevices act like getDeviceList in ofSerial which gives devicePath, deviceName, deviceID. I only need devicePath like ttyACM0.