ofProjectManager error on Ubuntu 10.04

Hiiii :smiley: im new here

I installed the ofProjectManager and write the correct path of to the oF directory, but it isnt work. I wrote in the shell the command from the readme file, and this is the result

matias@poderosa:~$ ofProject create prueba

Traceback (most recent call last):
File “/usr/local/bin/ofProject”, line 2, in
from ofProject import ofProject
File “/usr/local/ofProjectManager/ofProject.py”, line 2, in
import amara
ImportError: No module named amara

im running Ubuntu 10.04 and i can compile and run with codeblocks most of the examples. But i cant use the manager.
I have read this unsolved thread but the output of the shell is not exactly the same.
http://forum.openframeworks.cc/t/better-ofproject.py/2722/0
Sorry if is a silly question.

you need the package python-amara:

sudo apt-get install python-amara

it should be installed by the install script but perhaps there where some problem while installing it

Thanks a lot Arturo! :smiley: :smiley:
I installed this python module and works perfectly.

Here also same problem (Using Ubntu 10.04 LTS ) so installed python-amara using apt & solved that.

Again tried to create a project then comes another problem

  
tuxmanic@alexa:~$ ofProject create test  
/usr/lib/python2.6/sets.py:85: DeprecationWarning: functions overriding warnings.showwarning() must support the 'line' argument  
  stacklevel=2)  
/usr/lib/pymodules/python2.6/amara/bindery.py:4: DeprecationWarning: the sets module is deprecated  
  import sets  

assuming problem is with python version i just opened install_project_manager.sh & found that

  
gksudo -- bash -c 'apt-get install -y python2.5 python-amara   

I just tried to install python 2.5 using apt

  
  
tuxmanic@alexa:~$ sudo apt-get install python2.5  
Reading package lists... Done  
Building dependency tree         
Reading state information... Done  
Package python2.5 is not available, but is referred to by another package.  
This may mean that the package is missing, has been obsoleted, or  
is only available from another source  
E: Package python2.5 has no installation candidate  

Interesting python2.5 has no installation candidate, looks like python 2.5 is no longer available n official repo.

So My question is python 2.5 really necessary for Of to Work ? if yes it should installed from source or precompiled binary, right ?

You can safely ignore the deprecation warnings for the moment.
ofProjectManager will still work.

@grimus

you are right , project files are created but the error message is annoying !
actually what is that error ? also what about the python2.5 in install_project_manager.sh ?

assuming problem is with python version i just opened install_project_manager.sh & found that

  
>     gksudo -- bash -c 'apt-get install -y python2.5 python-amara   
>     

I just tried to install python 2.5 using apt

  
>     tuxmanic@alexa:~$ sudo apt-get install python2.5  
>     Reading package lists... Done  
>     Building dependency tree         
>     Reading state information... Done  
>     Package python2.5 is not available, but is referred to by another package.  
>     This may mean that the package is missing, has been obsoleted, or  
>     is only available from another source  
>     E: Package python2.5 has no installation candidate  
>     

Interesting python2.5 has no installation candidate, looks like python 2.5 is no longer available n official repo.

that’s because it’s a warning, not an error… .warnings you can often ignore.
afaik, this specific warning warns coders/developers that functions they use won’t be available in a future python release, so that they can adapt their code in time.

I had the same problem and i have installed python-amara as arturo mentioned… It did the trick, thank you for sharing the information, arturo…