ofImage issues in iOS

Hello,

I’m working on a game for iOS using oF and am having a problem with loading images that I cant seem to resolve.
The problem is that the image is not being displayed on the screen. I have tried the following things:

  1. Checked to see whether the image is actually being copied to the app bundle. I looked in the following directly and found the images were copied there:
    Library/Application Support/iPhone Simulator/6.1/Applications/D7C9FD57-D864-4E37-B02C-38590205ABF9/LogicNew.app

  2. As far as I can tell the image is being loaded correctly. I get a return of true from the ofImage loadImage() method.

  3. I am using pngs and have read that there is a known issue copying these onto iphones becuase the iphone API handles it differently to the freeimage lib. Ive now tried different files and have the same problem. I have also tried loading my images in the image loader ofExample and that works fine.

Has anyone experienced this before? Any suggestions or advice would be much appreciated.

Thanks in advance.

1 Like