ofGLFWWindowSettings was not declared in this scope


#1

Hi, I’m trying to build my OF project on RPi, but I get the following errors.

error: 'ofGLFWWindowSettings' was not declared in this scope
error: invalid static_cast from type 'ofAppBaseWindow' to type 'ofAppGLFWWindow'

My project manually creates a window using ofGLFWWindowSettings.
Is GLFW not compatible with Raspberry Pi?
Would there be any alternative that I can try? (or crossplatform solution?)

Thanks in advance!

P.S: I used OF 0.10.0 linuxarmv6l version to compile my project.


#2

no glfw is not compatible with the pi yet. you need to use ofEGLWindowSettings there.

If you don’t require very specific settings you can also just use ofGLWindowSettings in desktop and ofGLESWindowSettings in GLES platforms


#3

Thank you so much @arturo