ofAndroidLib error

Im trying to run OF in android im able to compile openframeworks libs im using ecplipse, nrdk9, OF 8.4 not sure what is going on the ofAndroidlib it has some errors someone knows how can i fix this?

Hi, I have had such problems on Eclipse in the past and I solved them with the setup indicated here:

You may try this setup.

Anyway I would suggest to continue with Android Studio as Google does not officially support the Eclipse-ADT plugin no more.

1 Like

Hi! ok yes eclipse is kind of weird i think im getting use to i was able compile an example but no more not sure why.
But ok i will try android studio i thought it sill in a experimental fase or of 0.9 has better support of this?

do you recommend following this guide http://openframeworks.cc/setup/android-studio/?

I didn’t mean Eclipse is weird. Android Studio is experimental for oF and oF is experimental for Android Studio. I know that but there is not too much choice for now. You can not run oF0.9.0’s android examples other then EmptyExample with Eclipse because of broken backward compatibility. EDIT: I managed to install androidAssimpExample so the last line here is wrong

Yes it is the only guide for now.

yeah ! is not weird is new for me so the word should be diferent from im used too and for eclipse im using 0.8.4 this version should work ok in eclipse?

I`m trying to setup android studio im getting the Gradle sync error.
I was reading at the troubleshooting already change the sdk version but i dont totally get this part -The Gradle version specified in /build.gradle where is that file and what value i have to change there? thanks

Now im getitng Error running build: Module ‘androidEmptyExample’ is not backed by gradle

Hello @lkkd,

Please see my above edit and my new post for your initial problem.

1 Like

:smile: aweesome! dude i will try in a bit

Cool! is working so good so far.

Hi! @Rancs
I been trying to run the examples in the simulator that use files and i realize that when you compile eclipse write other files in the bin folders y try putting the data folder in to other folder still cant read the file. i use ofLogNotice() << ofToDataPath(“jala”); to find where ir trying to load the file i get this directory :

i couldn’t find where do i have to place the files?

When I compiled assimp example with Eclipse, it took the resources from the project/data/bin folder and put them inside project/res/raw/ofdataresources.zip file. Right click project/res, then click Refresh. You will probably see the new created file.

I also compiled assimp example with Android Studio. It worked like a charm. I had not any issue.

Ok! thanks got it.

I still can’t run examples that have files in using the emulator the app run but nothing show up actually i messed up now i can’t run anything in the emulator the emulator show up but stays in the android scene and never open the app anyways i’m running now in a device an is perfectly running.