OF11 windows 10 videos

Hi,

I’m trying to run the ofVideoPlayer example on a Windows 10 PC and I’m having problems in runtime.

Without installing the K-lite 12.1.0 full or the latest 16.4.0, I get the following runtime error:
“Error occured while playing or pausing or opening the file”

After installing k-Lite 12.1.0 as suggested in other treads, I get the following runtime error:
“failed to find the video renderer”

In both cases the app runs but shows a black screen where the video was supposed to be.

What’s the catch here? What am I missing ?

Thanks for your help.

Yep, me too. Been trying different DirectShow installers, still none of them works. Video still doesn’t render.

hello,
i am not windows user, but can you give more details on the video you are using? container, encoding, dimensions, …
have you tried other videos? are you running the app in release or debug?
t

Hello,

I tried multiple videos of several formats and sizes (mp4, mov, avi) and I did try with debug and release compiles.

I also can play movies everywhere else (media player, vlc, Max, Processing, etc.)

I also tried it in Of.10.0.0 and I get the same error.

Thanks for the help.

That sounds like codecs are not installing ok

I followed the installations instructions and everything seems to be OK, got no errors.

Any tips ?

Has anyone figured this out? Having the same problem. It seems like oF is not aware that the codecs are on the computer. As @avperrotta said, the files play fine in a variety of players.

I’m on windows 10, I’d advise you to use this, as this has worked for me in the past.
Also I’ve just tried the video example and it is fine.
Please upload a snippet of the video somewhere and the code to play it.

Best,

P

Hello! You’re asking for the code using the ofVideoPlayer? I’ve tried it with several videos and formats including the fingers.mov included in examples/video/videoPlayerExample/bin/data/movies

//--------------------------------------------------------------

void ofApp::setup(){
	video.load("fingers.mov");
	video.setVolume(1.0);
	video.play();
}

//--------------------------------------------------------------
void ofApp::update(){
	video.update();
}

//--------------------------------------------------------------
void ofApp::draw(){
	video.draw(0, 0);
}

But if you think I’ll be better off using the HapPlayer, I’ll try it out!

Hi,

same here, even the video example with the finger.mov won’t work.

Thanks for the help.

André Perrotta

Apologies for not replying to this thread sooner.
This is an issue with the new K-Lite Codec pack and OF.

There is a code solution in the PR at the end of the issue, but also a K-Lite fix discussed too.

1 Like

It worked when I checked “Re-register DirectShow filters from K-Lite Codec Pack”. Thank you!!!

Wow,

the “Re-register DirectShow filters from K-Lite Codec Pack” did it.

That’s the kind of fix we like :slight_smile:

Thanks for the help.

1 Like

:smiling_face_with_three_hearts: hello Uhm I just started and pls be nice to me and hope we can all be friends.