OF Windows install with QT not matching paths correctly

Unsure whether this goes here because I didn’t configure something correctly or in the bugs section. Anyhow, here’s my issue: I have OF installed on a Win7 machine with QT. Now, if I want to create a new project (lets say in D:/UserFiles) I have to point to the OF install folder. So far so good. As soon as I try to build the project I get this error:

:-1: error: Error: Could not copy file ‘D:\UserFiles\test\C:\of_v0.9.2_msys2_release\export\msys2\fmodex.dll’ to ‘D:\UserFiles\test\bin\fmodex.dll’. Cannot open D:/UserFiles/test/C:/of_v0.9.2_msys2_release/export/msys2/fmodex.dll for input

I know the project creation wizard says that “please check that the project path in the previous page is 2 levels below the OF root”. But I also tried to create a project directly under the “examples” folder with the same results. The issue is clearly that despite having the drive letter as the start of the OF path the compiler appends it to the project folder. I tried to mess a little with relative paths in the QBS file but I haven’t managed much. Any ideas?

Hi,

I know it’s been some time, but for anyone who had the same issue, here is my solution:

Edit file
OF_PATH\libs\openFrameworsCompiled\project\qtreator\ofApp.qbs

and inside Transformer commented as “// Copy windows dlls from export to bin folder” change exportDir to the following:
//var exportDir = FileInfo.joinPaths(project.path, project.of_root, “export”, product.platform);
var exportDir = FileInfo.joinPaths(project.of_root, “export”, product.platform);

And voila, it should compile now :slight_smile: