OF runs on OpenSuse Leap 42.2

Hi all,
i found OF0.9.8 one week ago, and wonder if it’s possible to
run it on my System(OpenSuse Leap 42.2)?

Short answer: YES

One user posted a script on github 5 years ago:

https://github.com/openframeworks/openFrameworks/pull/2492/files#diff-3b141d80344b77ca53f7fda802303d39

that offers the way to install OF 0.9.8 on OpenSuse.

I updated the script install_dependencies.sh to make it
work on Leap 42.2 and give it back here, because i think
such an impressiv framework should run for OpenSuse users
as well:-)

Now here are step by step install instructions(as i’ve done):

  1. Download and extract OF0.9.8 inside /home/yourname
  2. Download following script(copy, paste to a texteditor)
    and save it as install_dependenciesSuse.sh
    in /home/yourname/of*/scripts/linux.
    Make the script executable(Filemanager/right click on file/properties/permissions/execute)
\#!/bin/bash

# Script for OpenSuse Leap 42.2

# usage: sudo ./install_dependenciesSuse.sh
# installs all required libraries for OF

zypper install freeglut-devel alsa-devel libXmu-devel libXxf86vm-devel gcc-c++ make boost-devel libraw1394-devel
gstreamer-devel gstreamer-plugins-base-devel libudev-devel libtheora-devel libvorbis-devel openal-soft-devel
libsndfile-devel python-lxml glew-devel flac-devel freeimage-devel cairo-devel libjack-devel portaudio-devel
libpulse-devel rtaudio-devel libcurl-devel

# A link to RtAudio.h in /usr/include/ makes the compiler happy :slight_smile:
ln -s /usr/include/rtaudio/RtAudio.h /usr/include/RtAudio.h

  1. In a terminal type:
    sudo ./install_dependenciesSuse.sh

    now watch at the terminal output to see if there are packages
    still not installed.

    To search a package:
    Open your packagemanager or
    copy-paste a package name to google it or
    visit software.opensuse.org to find the matching rpm-file.

    Install that rpm-file and the run the script again(No problem
    to run it several times).

    If all packages are installed the terminal output is filled
    with “package packagename is already installed”.

  2. Compile OF:
    /home/yourname/of*/scripts/linux/compileOF.sh
    if are you are in the correct path just type:
    ./compileOF.sh
    if compiler complains about “somefile.h” not found, that
    means a package is missing. To fix that google it e.g:
    somefile.h rpm opensuse
    Trust me google will find it:-)
    Then install that rpm and run ./compileOF.sh again.

  3. Test an example
    In terminal:(e.g.)
    cd home/yourname/Of*/examples/graphics/color
    make
    make RunRelease
    That runs well on my system so far.

  4. Embedding OF into some IDE
    I figured out how to compile, build and run an Of-app
    with CodeLite using make script from OF. More on
    that later(still testing).

Is it of any interest for someone?

In any case, I wish you success
and the best,
Thomas

1 Like

Using OpenSUSE Tumbleweed here, so YMMV, but just wanted to mention that I was able to build OF using what you have posted with the following additional steps before running compileOF.sh:

# zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ opensuse-multimedia-libs

# zypper install libopenssl-devel rtaudio-devel
# zypper si xrandr
1 Like

Hi! I’m trying to install in Tumbleweed, but the command:
# zypper si xrandr
turns this out:
Source package 'xrandr' for package 'xrandr' not found.

Also when running compileOF.sh it comes to this:

fatal error: uriparser/Uri.h: No such file or directory 7 | #include "uriparser/Uri.h" | ^~~~~~~~~~~~~~~~~ compilation terminated. make[1]: *** [makefileCommon/compile.core.mk:240: /home/taoteknohito/of_v0.11.2_linux64gcc6_release/libs/openFrameworksCompiled/lib/linux64/obj/Debug/libs/openFrameworks/graphics/ofImage.o] Error 1 make: *** [makefileCommon/compile.core.mk:212: Debug] Error 2 there has been a problem compiling Debug OF library please report this problem in the forums

Any idea on how to proceed?

Edit: solved like here forum.openframeworks.cc/t/problems-with-install-dependencies-sh-and-compileof-sh/29780

but replacing the with the relevant information for my issue.