Of + Qt Creator: installation problems on OS X


#1

Hello,
I’d like to use openFrameworks in Qt Creator 3.6.0, OS X 10.12.1 and maybe I’m doing something wrong because it doesn’t work in my setup.
I downloaded last 0.9.8 of release and launched the install_template.sh file inside the scripts/qtcreator folder. Console opens showing the command lines of the install script but nothing else seems to happen. I launch Qt Creator and select “new project” but no oF project template is shown. By reading the install script I understand that some openFrameworks wizard folders should be copied somewhere in Qt folder structure.
If that’s correct, where? Anyone knows what I’m missing? Thank you in advance.


#2

you have the full instructions on how to set it up on the web page: http://openframeworks.cc/setup/qtcreator/


#3

Thanks Arturo, actually I followed exactly the full instructions at that link, even multiple times to be sure not to be missing some detail but it does not work at all here. I suspect that the installing script it’s not executed or at least it’s not executed correctly. I googled a lot about .sh scripts and os x but can’t figure out what’s going on…


#4

can you try a newer version of qtcreator? as the guide says:

The current openFrameworks release (0.9.8) requires qtcreator 4.1.0.


#5

Ok, downloaded the 4.1.0 version, tried again but nothing changed, installer script does not work.
At last trying to understand where oF plugins folders should be copied I found a workaround:
I opened the Qt app package and copied in /Contents/Resources/templates/wizards the two folders “openFrameworks” and “openFrameworks update”. Now it works!


#6

off topic PS: I’m getting a huge list of compiler warnings but applications are successfully built and running.
Great!
:relaxed: