Of project generator bug

Im currently getting recurring issues when I use project generator to update programming examples from ofxOpenCv and someone elses repo.

The project was generated with the correct addons and theyre present. But ofxOpenCv isnt linking correctly.

There hopefully is a simple solution to this and I appreciate any help fixing it so I can go on way :slight_smile:

Hey!

I think it might be the extra libs you have in addons/ofxOpenCv/libs/opencv/osx/
you have opencv 2.a opencv 3.a etc

If you intend to link them ( not sure where they came from ) maybe remove the spaces from the names - I think that is what is breaking the linking stage of your project. Otherwise probably safer to delete all but opencv.a or move the others out of your OF folder.

You’ll have to regenerate the project with the PG once you do the above.

Hope that helps!
Theo

1 Like

Thanks so much Theo, I removed the space and it worked.
It is strange that occured though!?

Hi! Glad it worked.

I think the project generator doesn’t handle spaces well - so the space was causing it to treat the rest of the file name after the space as a new file.

Cheers!
Theo