OF on Raspberry Pi ignores MakeyMakey input

Hi,

I’m developing a simple app for Raspberry Pi. The only user interface will be through a MakeyMakey board. I’ve tried the app on OS X and works OK, but on the RPi the MakeyMakey input is ignored.

I’ve tried the MakeyMakey with other apps and works fine. The RPi Terminal gets its events alright. Does OF in RPi need some kind of special initialization to receive MakeyMakey input?

Not familiar with the MakeyMakey - do it’s apps have to be run as root?

Actually it’s just like a small usb keyboard. I can use it on other apps normally. But I shall give it a try running the app as root.

Do you think it’s possible that it conflicts with a regular keyboard if both MakeyMakey and a regular USB keyboard are plugged to the RPi at the same time?

Yes, it’s very possible that they conflict – right now on the Raspberry Pi we use a somewhat rudimentary event system for keyboard and mouse input. For example, it doesn’t support hot-plugging (but it could if someone wants to finish implementing it).

I’d guess that it will work if the makey makey is the only keyboard hooked up.

As a work-around, I’d suggest ssh’ing into the pi to control and start the program and only hook the pi up to the makey makey.

I’m having also problems getting the motorola lapdock’s keyboard to respond to OF events. It works great in the system but not in OF apps.
I guess is the early stage of the implementation as bakercp said.

1 Like

I’d suggest ssh’ing into the pi to control and start the program and only hook the pi up to the makey makey

I tried but I it doesn’t work either. Whenever I “hit” the makey makey spacebar I get this in the log:

[notice ] ofAppEGLWindow: readMouseEvents(): EV_KEY : unknown ev.code = 57

When running the app I get this output:

...
[warning] ofAppEGLWindow: setupKeyboard(): unabled to find keyboard
[ error ] ofAppEGLWindow: setupKeyboard(): did not open keyboard
[ error ] ofAppEGLWindow: setupKeyboard(): did not open keyboard, keyboard_fd < 0
...

I tried using a hacked numeric keyboard like [this one][1] [1]: http://anything.in.ua/images/sku_3652_1.jpg but the key code I get when hitting any of its keys is always 0. Same with numeric keyboard on my normal keyboard. I guess we may only use standard keyboards on it…

I tried also using one of those small number pad keyboards and all the events registered as 0s. I wonder if this is something we can fix in the source or if it is a driver issue? I used leafpad and was able to print out the events no problem…

My guess is that it’s a driver issue. I am currently using a hacked keyboard. Have not been able to fully test it yet, though.

@ThomasVanTa I’m having the exact same problem with OF and the lapdock. Wondering if you did find any solution to this so far?