of in puredyne?

hi

any one using OF in puredyne? puredyne.goto10.org
it is based on lenny so i guess it should be ok.

enrike

Any Debian based distribution should be easily compatible with OF.
If you have any problems, post them to the forum and we’ll help you out.

Fedora is compatible as well, but the package names are slightly different

hi again

i succeded to install the previous versions of OF in puredyne. i am trying now witih the latest but i get problems with few dependencies. I installed it manually with aptitude (puredyne preffers to use aptitude). CodeBlocks installs ok but when i try to install the libraries it wants to downgrade few of them. PureDyne is based on lenny.

On top of that it wants to remove couple of packages including Processing with i need for teaching…
gstreamer0.10-plugins-good
processing-gsvideo
puredyne-processing

this is the list of dependencies that wants to downgrade

libstdc++6-4.3-dev: Mendekotasuna:: gcc-4.3-base (= 4.3.2-1.1) baina 4.3.3-3 i
nstalatuta dago.
libsm-dev: Mendekotasuna:: libsm6 (= 2:1.0.3-2) baina 2:1.1.0-2 instalatuta da
go.
libice-dev: Mendekotasuna:: libice6 (= 2:1.0.4-1) baina 2:1.0.5-1 instalatuta
dago.
libtheora-dev: Mendekotasuna:: libtheora0 (= 1.0~beta3-1) baina 1.0-2 instalat
uta dago.
libglib2.0-dev: Mendekotasuna:: libglib2.0-0 (= 2.16.6-1+lenny1) baina 2.18.4-
2 instalatuta dago, eta mantendu egin da.
g+±4.3: Mendekotasuna:: gcc-4.3-base (= 4.3.2-1.1) baina 4.3.3-3 instalatuta
dago.
Mendekotasuna:: gcc-4.3 (= 4.3.2-1.1) baina 4.3.3-3 instalatuta dago.
libdc1394-22-dev: Mendekotasuna:: libdc1394-22 (= 2.0.2-1) baina 2.1.0-2 insta
latuta dago.
libgstreamer-plugins-base0.10-dev: Mendekotasuna:: libgstreamer-plugins-base0.
10-0 (= 0.10.19-2) baina 0.10.22-3 instalatuta dago, eta mantendu egin da.
libogg-dev: Mendekotasuna:: libogg0 (= 1.1.3-4) baina 1.1.3-5 instalatuta dago
.
zlib1g-dev: Mendekotasuna:: zlib1g (= 1:1.2.3.3.dfsg-12) baina 1:1.2.3.3.dfsg-
13 instalatuta dago.
libxml2-dev: Mendekotasuna:: libxml2 (= 2.6.32.dfsg-5) baina 2.7.3.dfsg-1 inst
alatuta dago.
libxau-dev: Mendekotasuna:: libxau6 (= 1:1.0.3-3) baina 1:1.0.4-2 instalatuta
dago.
libgstreamer0.10-dev: Mendekotasuna:: libgstreamer0.10-0 (= 0.10.19-3) baina 0
.10.22-2 instalatuta dago.
libvorbis-dev: Mendekotasuna:: libvorbis0a (= 1.2.0.dfsg-3.1) baina 1.2.0.dfsg
-4 instalatuta dago.
Mendekotasuna:: libvorbisenc2 (= 1.2.0.dfsg-3.1) baina 1.2.0.df
sg-4 instalatuta dago.
Mendekotasuna:: libvorbisfile3 (= 1.2.0.dfsg-3.1) baina 1.2.0.d
fsg-4 instalatuta dago.

I am not very good at this kind of issues so if anyone can give some hints i would be very happy… thanks

enrike

hi enrike

it’s weird it tries to uninstall gstreamer-good, as we use gstreamer.

can u try to install the dependencies one by one and tell us what is the conflicting package…

arturo

i have same issues with the new gstreamer setup in oF. but no time to look into it.
cant get it to work on debian-unstable or grml-stable. only works fine on ubuntu, which sucks.

is there a document which discribes what gstreamer-versions and plugins should be used?

for me its a real bummer. oF works so well, and tries to bring most depenencies in the package, but on the linux side these issue keept me from using 006 on linux. again, i had no time to figure it out, so its maybe just a tiny fix.

hey lian

i know at least two people that have installed oF in debian unstable, one of them really non-technical guy so it shouldn’t be so difficult. There’s two little things that change in the ffmpeg api but apart from that the install scripts in scripts/debian have been reported to work without problem.

what’s the error you’re having?

hey enrike

so just downloaded puredyne and it seems a problem with the distribution itself, there’s some development packages that are newer versions than the corresponding libs. i tried to installed at first without doing an apt-get update and everything seemed ok except some packages were missing but no dependency problem. but after updating there’s this problem with non synchronised packages.

so the only solution seems to wait till the puredyne maintainers update the repositories and all that packages are synchronised.

arturo

[quote author=“arturo”]hey lian

i know at least two people that have installed oF in debian unstable, one of them really non-technical guy so it shouldn’t be so difficult. There’s two little things that change in the ffmpeg api but apart from that the install scripts in scripts/debian have been reported to work without problem.

what’s the error you’re having?[/quote]

i had no time to look deeper into that issue, so i should do this before ranting on gstreamer. but the package-deps that gstreamer brings are sad. like the post above, to wait until package maintainers resolve/update pkgs is just bad. can this importand one, (video/camera playback) be independent of package-managers like most other libs shipped with oF?

will post error when i contiune to debug this.

the idea is having this libraries outside the whole package, we get a really lighter distribution, ffmpeg and gstreamer are really big also gstreamer has dependencies with glib and a few others so it seemed too much.

apart from that, it’s normal to have problems like this from time to time if you are using an unstable branch of debian.

yeah, but thats no solution. is there a tutorial how to resolve ffmpeg, gstreamer pkg issues? like what packages to look for and how to install without raping your other packages/envoirment completely.

you just need gstreamer0.10-dev and gstreamer0.10-base-dev. any version will do, the problem is not there, the problem is there’s some packages like libavcodec-dev that doesn’t match in the repositories with their corresponding lib so say they have libavcodec-dev 1.4 and libavcodec 1.3 (just making up the version numbers) so there’s no way to solve that unless you downgrade everything to match with libavcodec 1.3

i think if you wait some days it will be solved. or try reporting a bug to the ffmpeg package maintainers at debian.

arturo, thank you very much! will try to figure it out based on those bits, or wait like you said :slight_smile:

mmmm… i tried to install one by one but it is an awful lot of stuff to paste into the forum. Basically the problem is that puredyne is based on stable and testing.

I have done a safe-upgrade to make sure i am up to date with latest stuff in puredyne so that i can ask in their mailing list, maybe someone is using OF there, or they might be interested on supporting it. Now i tried again to install all dependencies at the same time, this is part of the output. Pretty similar to previous, there is few packages it wants to remove, some to be updated and some to be downgraded.

These packages are broken
libavcodec52 libavformat-dev libavutil-dev libswscale-dev

These have broken dependencies :
libavformat-dev: Mendekotasuna:: libavformat52 (= 3:0.svn20090303-1) baina 3:20080706-0.3 instalatuta dago.
libavcodec52: Mendekotasuna:: libavutil49 (< 3:0.svn20090303-99) baina 3:20080706-0.3 instalatuta dago. edo
libavutil-unstripped-49 (< 3:0.svn20090303-99) ; paketea birtuala da
libavutil-dev: Mendekotasuna:: libavutil49 (= 3:0.svn20090303-1) baina 3:20080706-0.3 instalatuta dago.
libswscale-dev: Mendekotasuna:: libswscale0 (= 3:0.svn20090303-1) baina 3:20080706-0.3 instalatuta dago.

To solve the issues above aptitude wants to :

  • REMOVE:
    cinelerra
    freej
    libavcodec51
    libquicktimehv
    libvlc0
    puredyne
    qdvdauthor
    transcode
    vlc
    xjadeo

  • INSTALL:
    libass1 [0.9.5-2 (testing)]
    libavfilter0 [3:0.svn20090303-1 (testing)]
    libdca0 [0.0.5-2 (testing)]
    libvlc2 [0.9.8a-3 (testing)]
    libvlccore0 [0.9.8a-3 (testing)]
    vlc-data [0.9.8a-3 (testing)]

  • UPGRADE:
    blender [2.46+dfsg-6 (stable, now) -> 2.48a+dfsg-2 (testing)]
    ffmpeg2theora [0.21-0.1 (stable, now) -> 0.24-2 (testing)]
    gstreamer0.10-ffmpeg [0.10.4-3 (stable, now) -> 0.10.7-1 (testing)]
    kino [1.3.0-2+lenny1 (stable, now) -> 1.3.3-1 (testing)]
    libsynfig0 [0.61.08-3 (stable, now) -> 0.61.09-2 (testing)]
    libsynfigapp0 [0.61.08-1+b1 (stable, now) -> 0.61.09-2 (testing)]
    synfigstudio [0.61.08-1+b1 (stable, now) -> 0.61.09-2 (testing)]
    vlc-nox [0.8.6.h-4+lenny2 (stable, stable, now) -> 0.9.8a-3 (testing)]

  • DOWNGRADE :
    ffmpeg [3:20080706-0.3 (stable, now) -> 3:0.svn20090303-1 (testing)]
    libavdevice52 [3:20080706-0.3 (stable, now) -> 3:0.svn20090303-1 (testing)]
    libavformat52 [3:20080706-0.3 (stable, now) -> 3:0.svn20090303-1 (testing)]
    libavutil49 [3:20080706-0.3 (stable, now) -> 3:0.svn20090303-1 (testing)]
    libpostproc51 [3:20080706-0.3 (stable, now) -> 3:0.svn20090303-1 (testing)]
    libquicktime1 [3:1.0.3+debian-1.3 (stable, now) -> 2:1.1.1+debian-1 (testing)]
    libswscale0 [3:20080706-0.3 (stable, now) -> 3:0.svn20090303-1 (testing)]

The puntuation of this aptitude solution is -1964

enrike

hi enrike

yes, i posted later, i installed puredyne and there’s a problem with their repositories as some dev packages (lot’s of them actually) are not synched with the binary equivalents.

you should wait some days and try again. puredyne seems to be based on some parts of debian unstable, and surely there’s the problem.

the unstable branches are were debian developers work and are not meant for being used except for testing. although many distributions and users use them and usually work without problem, it’s not granted that things like this aren’t going to happen.

i might drop an email in the puredyne mailing list as well. maybe somebody there is using OF as well

enrike