I am currently working on some projects that will be spanned over two screens. Therefore I can’t use OF_GAME_MODE. I just tested OF_FULLSCREEN instead and notice that as soon as I go fullscreen my framerate drops about 15 FPS even though the screen resolution is the same as for my Application. If I don’t go Fullscreen my App runs at 60fps, if I go fullscreen it runs with 45 FPS without any reason. When using Game Mode it runs at 60 FPS too. Is There any obvious reason for that?

According to the glut documentation, GAME_MODE should be more efficient than FULLSCREEN:


hmm thanks arturo. I was just wondering because if I run it in a window I get 60fps and as soon as I switch to fullscreen it drops. Thanks!

Hey Moka, what is the window resolution, and the resolution of your desktop? could fillrate be the bottleneck?

it’s both 1024*768 so there should not be much of a difference. I dunno maybe my MBP is too old. I am rendering a bloom effect if I disable it its also 60FPS at fullscreen. In game Mode it runs easy at 60FPS with all shader effects activated. In window mode also. I think something is wrong with my Computer related to fullscreen because 15fps is alot.

what do you mean with fillrate?

have you turned on ‘use extended desktop’?

http://forum.openframeworks.cc/t/fullscreen-dual-screen/693/12">Fullscreen dual screen]http://forum.openframeworks.cc/t/fullscreen-dual-screen/693/12

yes. does that make a difference if I am only on one screen?
for me it does not changy anything in terms of performance.

Is it exaclty 60 and 45 ?

This might not be your problem, if it dropped from 60 to 30 then it would make more sense, but if you have Vertical Sync on you’ll see drops for instance from 60 to 30.

If Vertcal Sync is on it will wait until the next screen refresh until doing the next frame, if it takes too long it’ll essentially wait longer than it has to, if V-Sync is off you’ll get screen tearing when things move a lot.

“Default Syncronize to Vertical Blank” is the one I think, worth a shot.


vsync is off. I simply guess that my graphics card does not like glut fullscreen that much.