OF audio in ubuntu 14.04 not work

I run AudioOutput OF example.
It work, i can see the sine wave but I not hearing nothing
if I run the AudioInput OF example, the pulseAudio Vol meter work good, the app run, but no detect audio in data.
See the app window here said those error’s:
“RtApiAlsa::getDeviceInfo: snd_pcm_open error for device (hw:1,0), Device or resource busy.”
“RtApiAlsa::probeDeviceOpen: pcm device (hw:0,3) won’t open for input.
In resume Of audio no work in ubuntu 14.04 over mi notebook sound card.
The other similar post are in older version of ubuntu and not have a solution.
Any samaritan person have a solution ? (if possible in Spanish). Thank.

Hi,

Just to say i have the same problem on Ubuntu 14.04;
so I sympathize while waiting to find a solution …:slight_smile:

to get realtime latency, rtaudio (the library we use for audio) uses directly alsa instead of going through the pulseaudio server. some applications take over the whole sound system and won’t let alsa playback. closing any other application like firefox… should fix this. also this is probably better using the nighly builds where we are using rtaudio from the system repositories.

1 Like

Hola, saludos desde Argentina, mis amigos informáticos me solucionaron el problema les pregunto a ellos que hicieron y te vuelvo a escribir.

Claudio

Hi Arturo!

How to ? Should i setup alsabase.conf like here ?
I never touch this…start reading about DAW and cgroups …

Hello I solved the problem here : http://stackoverflow.com/questions/6400950/how-can-i-solve-a-conflict-between-openframeworks-and-other-audio-applications

I Applied the first option.