Of 0.9 Android build error in windows 'find' command conflict

Windows10 x64, Android Studio 2 64, NDK r10e

Error here in build.gradle

/* Test to see that MinGW is installed properly */
proc = ["sh", "-c", "find --version"].execute()
proc.waitFor()
if (proc.exitValue() != 0) {
      throw new GradleException("Building on Windows requires MinGW and msys to be on PATH!\nPlease add both MinGW\\bin and MinGW\\msys\\1.0\\bin to your system PATH variable.")
}

I have already add mingw and msys to the PATH.

I follow this page to setup http://www.multigesture.net/articles/how-to-install-mingw-msys-and-eclipse-on-windows/
but MinGW installer is change a lot, so I chose the following selection.

Hi,

I tried to install it as well yesterday and ran into the exact same problem in the end. Tried to find solutions but without any success.

I attached the latest lof from Android Studio if it helps: idea.log.h (38.6 KB)

@GeistYp have you found a solution to this problem by any chance?

No, I just roll back to Android Studio 1.5 stable

And you don’t have this problem anymore? I use the version 1.5 as well but I still have this problem…

I think I find where the problem is.

find command not work, but I dont know how to fixed it in gradle.

PS. override ‘find’ by move msys path to top of PATH var works, like this

but I think this is not a good solution, you can try this. @Meach

1 Like

hello, i have the same problem in windows 10 x64 with of 0.9.8, Android Studio 1.5.
i add the path to Path variable system but not work

Error(73,0) CreateProcess error=2

log file:
idea.rar (11.0 KB)

HI!
finally, i change the ndk with r12b and work fine!