OF 0.9.8 / Ubuntu 16.04 LTS / QT does not work at all [solved]

Hi all,
I spent almost the whole day trying to get the above working.
I tried qt directly from the linked URL:
Qt 5.6.2 for Linux 64-bit (653 MB)
Qt Creator 4.4.0 for Linux 64-bit (120 MB)
Qt Online Installer for Linux 64-bit (31 MB).
All of them did not work. The first was best, it managed to load sources from the examples. Yes, I ran the installer scripts of OF and QT.
Now it is complaning about
_:-1: Fehler: Cannot lock build graph file ‘/gamez/Dokumente/Programmieren/of_v0.9.8_linux64_release/examples/video/build-videoGrabberExample-Desktop_Qt_5_6_2_GCC_64bit-Debug/qtc_Desktop__4164e6e4-debug/qtc_Desktop__4164e6e4-debug.bg’: Already locked by ‘QtCreator’ (PID 6590).

This file does not exist. I have 755-rights in the whole of-directory.

BTW: OF-documentation states that OF works only with QTcreator 4.1.0. In QT 5.6.2 there is QTcreator 4.0.3. The 4.4.0 creator does not work at all and the old versions on the QT site end with 2.6.

edit: I also needed a “sudo apt install qt4-qmake” to get rid of some error messages. Interestingly, “sudo apt install qt5-qmake” did not help, although QT version is 5.6.2.

Any suggestions to get this running?


you don’t need QT but only qt-creator.

OF 0.9.8 works beautifully with qt-creator 4.1.0 on Ubuntu 14.04 and 16.04.
here is the link to the qt-creator download page:


hope that helps

Hi bidul,
thanks for the hint. Same error as before:

Cannot lock build graph file '/gamez/Dokumente/Programmieren/of_v0.9.8_linux64_release/examples/graphics/build-fontShapesExample-Desktop-Debug/qtc_Desktop_60f1da3b-debug/qtc_Desktop_60f1da3b-debug.bg': Already locked by 'QtCreator' (PID 3459).

The file does not exist. All directories have chmod 755. User and group are same as my user.

Look like qtcreator interferes with itself, because PID 3459 is the PID of its own process. I found an explanation in qt-bugreports:
But creating some correct directory does not help.

Even compiling the examples on CLI does not work. A lot of error messages regarding Poco pop up.

So I am still not able to compile an example.

I have QT 5.8 with QTCreator 4.2.1 working fine with oF0.9.8 on Mint 18.1. In the past I’ve had to try different versions of QT to find one that works well with oF, and the newest versions of QT have sometimes had issues with oF. Here is a link to the QT archive page: http://download.qt.io/archive/qt/ . Also I’ve found that I have to re-run the scripts (to recompile POCO) and recompile the oF libraries after updating the kernel. I hope you can get it working. Maybe try some of the earlier versions of QT and/or QTCreator and see if that helps.

Thanks for the motivation. I found a helpful hint at askubunuto.com:

If you take a look into the “install_dependencies.sh” , you will see “-hwe-16.04” extension is defined by the “XTAG” variable and it used only for mesa lib (which is “free implementation of the OpenGL API”). Above the 16.04 (16.04.1, 16.04.2) you don’t need this special version anymore. So when you run “install_dependencies.sh” (without the “-y” switch) simply answer “no” to the question : “installing OF dependencies with -hwe-16.04 packages, confirm Y/N ?”

This allows me to make examples on the CLI. At least a small success. I will try and get the qtcreator working, perhaps with a different release…

Finally I got it working.

Step 1: during of/scripts/linux/ubuntu you have to say NO when you are asked about something like hwe-16.04. Then installation continues and builds poco.

Step 2: prior to building any project from the examples you have to manually create the directory named "build-<name_of_example>-Desktop-Release.

Not nice, but it works…

hi, old post, actual problem,

I’m trying to run OF 0.9.8 examples in Ubuntu.
the command linemake does the job but the qbs project does not.

Several compilation errors

/home/funambulium-display/of_v0.9.8_linux64_release/libs/poco/lib/linux64/libPocoNetSSL.a(ConsoleCertificateHandler.o) :-1: erreur : Dans la fonction « Poco::Net::ConsoleCertificateHandler::onInvalidCertificate(void const*, Poco::Net::VerificationErrorArgs&) » :
/home/funambulium-display/ConsoleCertificateHandler.cpp:-1: erreur : référence indéfinie vers « std::cout »
:-1: erreur : The following products could not be built for configuration qtc_Desktop_57412ea2-debug:

and a warning when opening the project

:-1: avertissement : Enabling linker flags compatibility mode. cpp.linkerFlags and cpp.platformLinkerFlags escaping is handled automatically beginning in Qbs 1.6. When upgrading to Qbs 1.6, you should only pass raw linker flags to these properties; do not escape them using -Wl or -Xlinker. This allows Qbs to automatically supply the correct linker flags regardless of whether the linker chosen is the compiler driver or system linker (see the documentation for cpp.linkerMode for more information). This message can be silenced by setting your Project's minimumQbsVersion to 1.6 (and the new behavior will take effect).

Any idea ?

Try this version: