OF 0.9.4 and QtCreator 4.1.0 (Linux)



I just grabbed the 0.9.4 release on the website, compiled it as usual (following instructions on the website as well) and everything compiled fine.

I then installed QtCreator 4.1.0 and installed the templates from my “oF” directory

When I create a new openFrameworks project I get various errors concerning helpers.js and deprecated syntax in .qbs files …

Looking at the GitHub issues, this is what is supposed to be fixed in 0.9.4 and has been merged, and downloading a release on GitHub releases pages did fix it.

I’m on debian jessie 8.6.0

So, my question is, do I need to download OF 0.9.4 from another place?



@justadude - thanks for posting this!
I’m downloading it now to double check, as it could have been generated from the wrong branch ( this happened first time we tried to the 0.9.4 RC 1 )


Hmm - it is the 0.9.4 release.
Could you see if the RC 1 we posted a few days ago works for you?

Pinging @arturo


@theo you’re welcome,

I grabbed the RC1 you linked but it didn’t help out either.

As another attempt, I cloned the git repository locally, and used the ./install_template script directly from there but still no luck.

I then removed all my QtCreator related files (~/.config/QtCreator) and downloaded an archived version of QtCreator 4.0.3 for linux from here , I re-compiled v0.9.4 (stable), re-installed the templates and it all went fine.

Anyway thanks for the help.


the packages were wrong, i updated them some hours ago, if you can try to download it again?


Hi @arturo,

Yes thanks it all works OF 0.9.4 + QtCreator 4.1.0 :grin: