OF 0.9.0 Raspberry Pi 2 and BPlus

I had one installed OF and I work well - but I needed new SD cards and started from scratch.

  1. the curl doesn’t load the gz file - just an URL descriptor, but wget does
    load the gz file. This is what I get:
    This is what I get with the curl command

    root@rpiBPlus-251:/home/pi# curl -O

     % Total    % Received % Xferd  Average Speed   Time    Time    

    Time Current Dload Upload Total Spent
    Left Speed

    100 184 100 184 0 0 540 0 --:–:-- --:–:--
    –:--:-- 542

    root@rpiBPlus-251:/home/pi# cat of_v0.9.0_linuxarmv6l_release.tar.gz

    301 Moved Permanently

    301 Moved Permanently

  2. After a complete Install on a RPi BPlus and a RPI 2. No errors were noticed
    (I assume there must be a log file???) and I started the example Program on both system (Memory set to 64) but all I got on the screens was a dark gray block, but no contents were display (the rotating graphic) . The Screen is a old 24" FlexScan F930… the old 14" screen was defect. I wonder if this is a pure screen function.

Can someone advice me?

The first issue could be caused by the new servers used for the website, there is a lot of issues with the documentation right now too.

For the second, what happens when you put more memory ?

I tested once with mem sta at 64, and again using 128. Same result.

Thank you for your assistace.

Do you see the terminal on your screen ?

I saw a dark grey “block” where the graphics should have been.
The mouse poiter was not displayable when moved to the grey block and it masked all tha was behind it.

This is the listing of the example programmes make run:

make[1]: Leaving directory ‘/home/pi/openFrameworks/apps/myApps/myRpiApp’
root@rpi-bplus-242:/home/pi/openFrameworks/apps/myApps/myRpiApp# make run
checking pkg-config libraries: cairo zlib gstreamer-app-1.0 gstreamer-1.0 gstreamer-video-1.0 gstreamer-base-1.0 libudev freetype2 fontconfig sndfile openal openssl libpulse-simple alsa gtk±3.0
[notice ] ofAppEGLWindow: setupRPiNativeWindow(): screenRect: 1920x1080
[notice ] ofAppEGLWindow: setupRPiNativeWindow(): windowRect: 1024x768
[notice ] ofAppEGLWindow: createSurface(): setting up EGL Display
[notice ] ofAppEGLWindow: createSurface(): EGL Display correctly set 0x1
[notice ] ofAppEGLWindow: createSurface(): no current renderer selected
[notice ] ofAppEGLWindow: createSurface(): default renderer detected
[notice ] ofAppEGLWindow: createSurface(): surface created correctly
[notice ] ofAppEGLWindow: createSurface(): API bound correctly
[notice ] ofAppEGLWindow: createSurface(): -----EGL-----
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION_MAJOR = 1
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION_MINOR = 4
[notice ] ofAppEGLWindow: createSurface(): EGL_CLIENT_APIS = OpenGL_ES OpenVG
[notice ] ofAppEGLWindow: createSurface(): EGL_VENDOR = Broadcom
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION = 1.4
[notice ] ofAppEGLWindow: createSurface(): EGL_EXTENSIONS = EGL_KHR_image EGL_KHR_image_base EGL_KHR_image_pixmap EGL_KHR_vg_parent_image EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_lock_surface
[notice ] ofAppEGLWindow: createSurface(): GL_RENDERER = VideoCore IV HW
[notice ] ofAppEGLWindow: createSurface(): GL_VERSION = OpenGL ES-CM 1.1
[notice ] ofAppEGLWindow: createSurface(): GL_VENDOR = Broadcom
[notice ] ofAppEGLWindow: createSurface(): -------------
[notice ] ofAppEGLWindow: setupPeripherals(): peripheral setup complete
[notice ] ofAppEGLWindow: setupNativeUDev(): created udev object
[notice ] ofAppEGLWindow: setupMouse(): mouse_fd= 5 devicePath=/dev/input/by-path/platform-20980000.usb-usb-0:
[notice ] ofAppEGLWindow: setupMouse(): mouse device name = Logitech USB-PS/2 Optical Mouse
[notice ] ofAppEGLWindow: setupKeyboard(): keyboard_fd= 6 devicePath=/dev/input/by-path/platform-20980000.usb-usb-0:1.4.2:1.0-event-kbd
[notice ] ofAppEGLWindow: setupKeyboard(): keyboard device name = BTC USB Multimedia Keyboard
[notice ] ofAppEGLWindow: setupPeripherals(): native event setup complete

Can you try it on a hdtv ?

I do not have a dgtv or a hdmi monitor - only vga monitors

I got another monitor Samsung SyncMaster 2243 lnx from my neighbour
and retested and got exactly the same effect. Grey block and no graphics.
I used a RPI- latest jessie and upgrades.

I have made a log of the output from the install_depenancies , compile and the example makes.

I am making no progress , please help.

how omxplayer works ?

It uses the same basic function for talk with the videocore it seems.

My Issue has now been resolved. It is now working.

omxplayer? No a theme in this Topic?

OmxPlayer, like OpenFrameworks, doesn’t need a desktop environment for display graphics.

It uses the same rpi libraries for communicate with the GPU.

So if omxplayer worked, it was an issue in openframeworks, not outside of it, like a physical default.

So, how you solved your issue ?