OF 0.7.4 and CodeBlocks 12.11 "cannot find -lstrmbase" error

Hi all,

I am trying to setup OF 0.7.4 under CodeBlocks 12.11 in a Windows Vista machine.

I’ve setup CodeBlocks 12.11 and copied the codeblocks_additions in mingw/include and mingw/lib.

I can compile the library (openFrameworksLib.cbp project) but when I try to compile any example I get “cannot find -lstrmbase” error.

I think this error was related to not copying properly codeblocks_additions in earlier versiorns (OF 0.7.3 and under with CB 10.05) but I’ve double checked I am copying these files.

Has anybody else experienced this problem?

Regards.

Hi Eduardo
had experienced the same issue when I installed OF 0.7.4 with CB 12.11
Now I tried to go back to OF 0.7.3 with CB 10.05 and still had the issue
“ld.exe cannot find -lstrmbase”
“ld.exe cannot find -lz”
I fixed it with changing the path C:/MinGw with codeblock minGw path C:\Program Files (x86)\CodeBlocks\MinGW

Hi Paul,

That path change in CB for mingw fixed it!

Thanks a lot for sharing the solution.

I also getting same pblm as …I hv same class path as above but still same pblm…I am using CodeBlocks…10.05… Help m out

be sure to follow step (e) in the codeblocks setup guide. You are missing those libs and headers.

here’s the guide: http://www.openframeworks.cc/setup/codeblocks/

i setted up the path but kw i am not getting the previuos “lstrmbase error” but new 19 errors occured