OF 0.11.1 Release is out

Hi all,

0.11.1 ( patch-release ) is out.
It contains mostly bug fixes, but also support for macOS 11.0 and Apple Silicon chips.

To see the changes check out the changelog:

As well as this issue list:

If people run into any new bugs/issues or regressions please report it here or open an issue on our GitHub

Thanks to everyone who helped test 0.11.1 and provided comments, bug reports and fixes!

Unless there are major regressions the next release will be tracked in this issue:

Thanks all!


Nice one! Thank you to everyone who worked on this. I really admire your skill and generosity and hope some day I can help contribute, too.

1 Like


Looking forward to testing it on the RPI4.

Thanks a lot,

1 Like

great, thanks a lot everyone involved

Am I right in the assumption that this doesn’t work on macOS 10.14.6 Mojave?


It definitely does work on 10.14.6 :slight_smile:
That is the OS I am still running day to day. Are you having issues with 0.11.1 on 10.14?


1 Like

Yes, I simply downloaded the ZIP file, extracted openFrameworks, renamed the extracted folder to “macOS_0.11.1”, and placed it inside the same directory as 0.11.0 in /Developer/openFrameworks/.

Then I tried to compile the 3DModelLoaderExample as a quick test, and I got the following linker error:

Is this because I renamed the extracted folder?

That is really weird.
Can you try not renaming it, but just compiling straight after unzipping it ( and keep it in your Downloads/ folder)?

If that doesn’t work it could be a conflict with a system level library.

Which Xcode version are you on?
I would recommend Xcode 11.2.1 or newer.

1 Like

I just tried that and the same linker errors happen, as in the above screenshot. This time I tried compiling the 3dPrimitivesExample.

I’m currently using Xcode 10.3 and it doesn’t seem like a newer version is available on macOS 10.14.

Ah okay.
I just tried on Xcode 9 and get the same error as you.
This might be something we can fix on the CI at some point, but in the meantime you will need Xcode 11.

Xcode 11.2 through to 11.3.1 are available for 10.14.6
Go to: https://developer.apple.com/download/more/ ( you will need to sign in with your developer account ) and scroll down to Xcode 11.3.1 or 11.2.1 ( that is what I have and works fine with 0.11.1 )

Haha, if only I had a developer account, but I know somebody who does have one. Thanks for your support, Theo!

Hi! You can get the free account and still download the older versions of xcode.

1 Like

yes u can
u dont have to pay for xcode just yet

For older Xcode versions without any dev license:

this looks super helpful! One thing is to note is that there have been issues with people downloading modified Xcodes in the past (XcodeGhost - Wikipedia) so please be careful / check on this. these are xip (signed zips) and it all looks legit.

1 Like

what a curious history… 4000 infected apps.
btw now I see that it seems that you must be logged to the dev account.
I have a free/expired account and I was logged.