Not showing OF Window on RPI2 when using ofSerial/ofxOscuino OSC linking to Arduino

Hello,
I am using ofxOscuino from @workergnome to send OSC data to and from Arduino through the USB.
I don’t know if it has any sense, but when I comment/bypass the serial connection line:

serialARDUINO.setup("/dev/ttyACM0", arduinoBaud);

, it works fine: the window appears correctly.

To enable access to the ‘pi’ user and not to ‘root’ only, I added the user to this groups like this:

sudo gpasswd -a pi uucp
sudo gpasswd -a pi lock
sudo gpasswd -a pi tty

and I verified ‘pi’ is on there using this:

cat /etc/group | grep uucp
cat /etc/group | grep lock
cat /etc/group | grep tty

I am working on 0.9.3 on Archlinux and OSX too, where the project runs fine, sending/receiving OSC to/from Arduino.

I tried with OF_FULLSCREEN or OF_WINDOW in main.cpp and that’s what it shows when staring to run the app:

Any help where can I start to check?

EDIT: BTW… the ‘serialExample’ is showing the window correctly…

have you tried running your app as sudo ?

you might have to do it manually

cd bin
sudo ./yourApp

hey, thanks for the reply. yes, I tried with sudo too. If I just unplug the usb and run (same app), the window opens fine.

… I modified the code to enable the serial connection manually with a key and the app opens fine, but when enabling the serial connection with another key, it hangs the app. Do not goes back disabling/disconnecting serial again with another key and must close the app with ctrl+c…

I am thinking to try another “more solid addon” (besides ofxOscuino) like ofxSerial:

It has new functions for OSC/SLIP communication.