normalizing option nomenclature

the naming of some functions are inconsistent:

  
  
ofHideCursor()/ofShowCursor()  
  
ofEnableArbTex()  
ofEnableSetupScreen()  
ofEnableDataPath()  
ofEnableAlphaBlending()  
ofEnableSmoothing()  
  
ofToggleFullscreen()  
  
ofSetFullscreen()  
ofSetVerticalSync()  
  

i think the best solution is to switch everything to the last format, ofSetX(true/false).

thoughts?

discussion should be here on the forum, but the issue on github in question is https://github.com/openframeworks/openFrameworks/issues/249#issuecomment-2995120

Nice thinking, and I think that makes a lot of sense. Though enable/disable does have the natural language thing going for it, it’s a bit less API-ish (if that makes sense). I’ve never noticed ofToggleFullscreen() but that one is a less “principle of least surprise”. ofSetX(true/false) makes sense in most cases, though ofSetCursor(true) seems odd to me for some reason.

i totally understand how ofSetCursor() or ofSetCursorVisibility() feels strange. processing has cursor() and noCursor(), which corresponds to things like stroke()/noStroke(), where the “enable” version also takes an argument.

ofToggleFullscreen() also feels very natural, even though it’s the only one of its kind. but it would also be unnecessary if OF had a cross-platform “fullscreen” key combo… first we need access to key modifiers though :slight_smile: