Newb to OF and PI, how to compile?


#1

Hi, I have been using OF for a little bit now, and trying to it to run on a PI for a school project.

I have it all installed as far as I can tell but stuck on the last set of instructions from the setup guide.

cd /home/pi/openFrameworks/examples/graphics/polygonExample
make
make run

When I run that - it does stuff in the terminal - but should I be seeing the graphic pop up after it compiles?

Not sure what I should be expecting here!

Thanks :slight_smile:


#2

Hi,

If you are using with a monitor, I believe the compilation gives you the steps to follow afterwards:


     compiling done
     to launch the application

     cd bin
     ./appName

     - or -

     make RunRelease


make[2]: Leaving directory '/home/pi/oF/apps/myApps/appName'

so just run make RunRelease, the graphical interface should pop up unless you have ofNoAppWindow in your main.cpp. If it’s an example, the window should pop up there is no examples without windows on the of_v0.10.1_linuxarmv6l_release .

Hope this helps.

++

P


#3

Thanks for your reply!

I type make RunRelease and get this:

make RunRelease

HOST_OS=Linux
checking pkg-config libraries: cairo zlib gstreamer-app-1.0 gstreamer-1.0 gstreamer-video-1.0 gstreamer-base-1.0 libudev freetype2 fontconfig sndfile openal libcurl glfw3 rtaudio gtk±3.0
with PKG_CONFIG_LIBDIR=
[warning] ofAppEGLWindow: init(): X11 not availble on RPI yet, using a native window instead
[notice ] ofAppEGLWindow: setupRPiNativeWindow(): screenRect: 1920x1080
[notice ] ofAppEGLWindow: setupRPiNativeWindow(): windowRect: 1024x768
[notice ] ofAppEGLWindow: createSurface(): setting up EGL Display
[notice ] ofAppEGLWindow: createSurface(): EGL Display correctly set 0x1
[notice ] ofAppEGLWindow: createSurface(): no current renderer selected
[notice ] ofAppEGLWindow: createSurface(): default renderer detected
[notice ] ofAppEGLWindow: createSurface(): surface created correctly
[notice ] ofAppEGLWindow: createSurface(): API bound correctly
[notice ] ofAppEGLWindow: createSurface(): -----EGL-----
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION_MAJOR = 1
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION_MINOR = 4
[notice ] ofAppEGLWindow: createSurface(): EGL_CLIENT_APIS = OpenGL_ES OpenVG
[notice ] ofAppEGLWindow: createSurface(): EGL_VENDOR = Broadcom
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION = 1.4
[notice ] ofAppEGLWindow: createSurface(): EGL_EXTENSIONS = EGL_KHR_image EGL_KHR_image_base EGL_KHR_image_pixmap EGL_KHR_vg_parent_image EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_lock_surface
[notice ] ofAppEGLWindow: createSurface(): GL_RENDERER = VideoCore IV HW
[notice ] ofAppEGLWindow: createSurface(): GL_VERSION = OpenGL ES-CM 1.1
[notice ] ofAppEGLWindow: createSurface(): GL_VENDOR = Broadcom
[notice ] ofAppEGLWindow: createSurface(): -------------
[notice ] ofAppEGLWindow: setupPeripherals(): peripheral setup complete
[notice ] ofAppEGLWindow: setupNativeUDev(): created udev object
[notice ] ofAppEGLWindow: setupMouse(): mouse_fd=5 devicePath=/dev/input/by-path/platform-3f980000.usb-usb-0:1.5:1.2-event-mouse
[notice ] ofAppEGLWindow: setupMouse(): mouse device name = Logitech TK820
[notice ] ofAppEGLWindow: mouse x axis min, max: 0, 0
[notice ] ofAppEGLWindow: mouse y axis min, max: 0, 0
[notice ] ofAppEGLWindow: setupKeyboard(): keyboard_fd=6 devicePath=/dev/input/event0
[notice ] ofAppEGLWindow: setupKeyboard(): keyboard device name = Logitech TK820
[notice ] ofAppEGLWindow: setupPeripherals(): native event setup complete

and nothing else :confused:


#4

Hi,

Well this is odd, unless you are running it through a Virtual Network Computer, the window should pop up.

Your console output seem normal…

Did you change the settings for the GL Driver to be legacy?

sudo raspi-config 

then Advanced Options then GL drivers:

I just tried it -just now- with a fresh install from saturday on mine, and it works fine.

Did you follow all the steps from the guide?
In particular installing the dependencies, and maybe you also need to install the codecs?

cd /home/pi/openFrameworksInstallLocation/scripts/linux/debian
sudo ./install_codecs.sh
sudo ./install_dependencies.sh

Hope it gets resolved,

++


#5

Ah! I am running through VNC, apologies if that was required information!

I’ll try tomorrow and report back, thanks for going to that effort!


#6

Also you can view the window with VNC enabling the experimental direct capture mode, but you won’t have mouse or keyboard inside the window

http://zleap.net/wp-content/uploads/2017/02/Screenshot-from-2017-02-16-21-03-57-1024x699.png


#7

Works as soon as I use the external monitor :roll_eyes:

As does the direct capture mode on my monitor via VNC, note on mine it is no longer named experimental direct capture, just direct capture :slight_smile:

Thanks for the help, I’ll be around! :slight_smile: